WooCommerce has a Cross-Site Scripting (XSS) Vulnerability in checkout & registration forms
CVE-2024-37297GHSA-cv23-q6gh-xfrf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (woocommerce/woocommerce 8.9.3, 8.8.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist woocommerce/woocommerce
- Affected
- >= 8.8.0, < 8.8.5>= 8.9.0, < 8.9.3
- Fixed in
- 8.9.3, 8.8.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cv23-q6gh-xfrf lists affected ranges: Packagist woocommerce/woocommerce >=8.8.0 =8.9.0 <8.9.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-37297: 0.48% estimated exploitation activity in the next 30 days; percentile 41.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability introduced in WooCommerce 8.8 allows for cross-site scripting. A bad actor can manipulate a link to include malicious HTML & JavaScript content. While the content is not saved to the database, the links may be sent to victims for malicious purposes. The injected JavaScript could hijack content & data stored in the browser, including the session. The URL content is read through the Sourcebuster.js library and then inserted without proper sanitization to the classic checkout and registration forms. Patches Workarounds Disabling the Order Attribution feature References A8C SIRT: p3btAN-2L2-p2 (internal) Public disclosure: https://developer.woocommerce.com/2024/06/10/developer-advisory-xss-vulnerability-8-8-0/
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-cv23-q6gh-xfrf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-37297 Advisory: WooCommerce has a Cross-Site Scripting (XSS) Vulnerability in checkout & registration forms IDs: CVE-2024-37297, GHSA-cv23-q6gh-xfrf Record: https://patchnext.com/advisories/cve-2024-37297 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: woocommerce/woocommerce 8.9.3, 8.8.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist woocommerce/woocommerce: affected >= 8.8.0, < 8.8.5; >= 8.9.0, < 8.9.3; fixed in 8.9.3, 8.8.5 ## Suggested inspection (read-only) - Packagist woocommerce/woocommerce: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on woocommerce/woocommerce. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-cv23-q6gh-xfrf (GitHub-reviewed advisory GHSA-cv23-q6gh-xfrf lists affected ranges: Packagist woocommerce/woocommerce >=8.8.0 =8.9.0 <8.9.3) Commands are suggestions: review each one before running it.
Loading voting…