Skip to content

← Actionable
Medium, CVSS 5.5

Aimeos denial of service vulnerability in SaaS and marketplace setups

CVE-2024-37294GHSA-xjm6-jfmg-qc6p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (aimeos/aimeos-core 2024.04.7, 2023.10.17, 2022.10.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist aimeos/aimeos-core

    Affected
    >= 2024.04.1, < 2024.04.7>= 2023.04.1, < 2023.10.17>= 2022.04.1, < 2022.10.17
    Fixed in
    2024.04.7, 2023.10.17, 2022.10.17

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2024-37294: 0.43% estimated exploitation activity in the next 30 days; percentile 37.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All SaaS and marketplace setups using Aimeos version from 2022/2023/2024 are affected by a potential denial of service attack Patches Upgrade to the latest 2022.10 LTS, 2023.10 LTS and 2024.04.7 version of the aimeos/aimeos-core package

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xjm6-jfmg-qc6p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-37294

Advisory: Aimeos denial of service vulnerability in SaaS and marketplace setups
IDs: CVE-2024-37294, GHSA-xjm6-jfmg-qc6p
Record: https://patchnext.com/advisories/cve-2024-37294 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: aimeos/aimeos-core 2024.04.7, 2023.10.17, 2022.10.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist aimeos/aimeos-core: affected >= 2024.04.1, < 2024.04.7; >= 2023.04.1, < 2023.10.17; >= 2022.04.1, < 2022.10.17; fixed in 2024.04.7, 2023.10.17, 2022.10.17

## Suggested inspection (read-only)
- Packagist aimeos/aimeos-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on aimeos/aimeos-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xjm6-jfmg-qc6p (GitHub-reviewed advisory GHSA-xjm6-jfmg-qc6p lists affected ranges: Packagist aimeos/aimeos-core >=2024.04.1 =2023.04.1 =2022.04.1 <2022.10.17)

Commands are suggestions: review each one before running it.

Loading voting…