github.com/containers/image allows unexpected authenticated registry accesses
CVE-2024-3727GHSA-6wvf-f2vw-3425
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containers/image/v5 5.30.1, 5.29.3; github.com/containers/image 5.30.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/containers/image/v5
- Affected
- >= 5.30.0, < 5.30.1< 5.29.3
- Fixed in
- 5.29.3, 5.30.1
Go github.com/containers/image
- Affected
- < 5.30.1
- Fixed in
- 5.30.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6wvf-f2vw-3425 lists affected ranges: Go github.com/containers/image >=0 =5.30.0 =0 <5.29.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-3727: 1.28% estimated exploitation activity in the next 30 days; percentile 70.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A flaw was found in the github.com/containers/image library. This flaw allows attackers to trigger unexpected authenticated registry accesses on behalf of a victim user, causing resource exhaustion, local path traversal, and other attacks.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6wvf-f2vw-3425
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-3727 Advisory: github.com/containers/image allows unexpected authenticated registry accesses IDs: CVE-2024-3727, GHSA-6wvf-f2vw-3425 Record: https://patchnext.com/advisories/cve-2024-3727 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/containers/image/v5 5.30.1, 5.29.3; github.com/containers/image 5.30.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/containers/image/v5: affected >= 5.30.0, < 5.30.1; < 5.29.3; fixed in 5.29.3, 5.30.1 - Go github.com/containers/image: affected < 5.30.1; fixed in 5.30.1 ## Suggested inspection (read-only) - Go github.com/containers/image/v5: check the installed version with your package manager. - Go github.com/containers/image: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/containers/image/v5, github.com/containers/image. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6wvf-f2vw-3425 (GitHub-reviewed advisory GHSA-6wvf-f2vw-3425 lists affected ranges: Go github.com/containers/image >=0 =5.30.0 =0 <5.29.3) Commands are suggestions: review each one before running it.
Loading voting…