Cross-site scripting (XSS) vulnerability in Description metadata
CVE-2024-37160GHSA-5pxr-7m4j-jjc6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getformwork/formwork 2.0.0-beta.2, 1.13.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getformwork/formwork
- Affected
- < 1.13.1>= 2.0.0-beta.1, <= 2.0.0-beta.1
- Fixed in
- 2.0.0-beta.2, 1.13.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5pxr-7m4j-jjc6 lists affected ranges: Packagist getformwork/formwork >=0 =2.0.0-beta.1 <=2.0.0-beta.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-37160: 0.46% estimated exploitation activity in the next 30 days; percentile 40.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Regardless of the role or privileges, no user should be able to inject malicious JavaScript (JS) scripts into the body HTML. an XSS (Cross-Site Scripting) vulnerability, specifically a Stored XSS, which affects all pages of the website. Once the JS script is embedded in the body HTML, the XSS will trigger on any page a victim visits, such as the about, blog, contact, or any other pages, except for the panel. Impact This vulnerability allows attackers to inject malicious JS or HTML through a crafted payload into the vulnerable spot, achieving persistence and attacking numerous visitors or anyone accessing the website. The attack can be widespread and affect many users because the malicious JS will execute on every page, unlike an injection on a specific page (e.g., injecting on the About page would only affect that page). In this case, a single injection point leads to the execution of the malicious JS on all pages. Patches - Formwork 1.13.1 has been released with a patch that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5pxr-7m4j-jjc6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-37160 Advisory: Cross-site scripting (XSS) vulnerability in Description metadata IDs: CVE-2024-37160, GHSA-5pxr-7m4j-jjc6 Record: https://patchnext.com/advisories/cve-2024-37160 (revision 1, source checked 26 Oct 2026, 14:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getformwork/formwork 2.0.0-beta.2, 1.13.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getformwork/formwork: affected < 1.13.1; >= 2.0.0-beta.1, <= 2.0.0-beta.1; fixed in 2.0.0-beta.2, 1.13.1 ## Suggested inspection (read-only) - Packagist getformwork/formwork: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getformwork/formwork. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5pxr-7m4j-jjc6 (GitHub-reviewed advisory GHSA-5pxr-7m4j-jjc6 lists affected ranges: Packagist getformwork/formwork >=0 =2.0.0-beta.1 <=2.0.0-beta.1) Commands are suggestions: review each one before running it.
Loading voting…