activeadmin vulnerable to stored persistent cross-site scripting (XSS) in dynamic form legends
CVE-2024-37031GHSA-9mg6-x45v-hcfm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (activeadmin 4.0.0.beta7, 3.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems activeadmin
- Affected
- < 3.2.2>= 4.0.0.beta1, < 4.0.0.beta7
- Fixed in
- 4.0.0.beta7, 3.2.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9mg6-x45v-hcfm lists affected ranges: RubyGems activeadmin >=0 =4.0.0.beta1 <4.0.0.beta7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2024-37031: 0.35% estimated exploitation activity in the next 30 days; percentile 28.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users settings their active admin form legends dynamically may be vulnerable to stored XSS, as long as its value can be injected directly by a malicious user. For example: A public web application allows users to create entities with arbitrary names. Active Admin is used to administrate these entities through a private backend. The form to edit these entities in the private backend has the following shape (note the dynamic name value dependent on an attribute of the resource): Then a malicious user could create an entity with a payload that would get executed in the active admin administrator's browser. Both form blocks with an implicit or explicit name (i.e., both form resource.name or form name: resource.name would suffer from the problem), where the value of the name can be arbitrarily set by non admin users. Patches The problem has been fixed in ActiveAdmin 3.2.2 and ActiveAdmin 4.0.0.beta7. Workarounds Users can workaround this problem without upgrading by explicitly…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9mg6-x45v-hcfm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-37031 Advisory: activeadmin vulnerable to stored persistent cross-site scripting (XSS) in dynamic form legends IDs: CVE-2024-37031, GHSA-9mg6-x45v-hcfm Record: https://patchnext.com/advisories/cve-2024-37031 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: activeadmin 4.0.0.beta7, 3.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems activeadmin: affected < 3.2.2; >= 4.0.0.beta1, < 4.0.0.beta7; fixed in 4.0.0.beta7, 3.2.2 ## Suggested inspection (read-only) - RubyGems activeadmin: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on activeadmin. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9mg6-x45v-hcfm (GitHub-reviewed advisory GHSA-9mg6-x45v-hcfm lists affected ranges: RubyGems activeadmin >=0 =4.0.0.beta1 <4.0.0.beta7) Commands are suggestions: review each one before running it.
Loading voting…