BookStack Incorrect Access Control vulnerability
CVE-2024-36676GHSA-pj36-fcrg-327j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ssddanbrown/bookstack 24.05.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ssddanbrown/bookstack
- Affected
- < 24.05.1
- Fixed in
- 24.05.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pj36-fcrg-327j lists affected ranges: Packagist ssddanbrown/bookstack >=0 <24.05.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-36676: 0.65% estimated exploitation activity in the next 30 days; percentile 51.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Incorrect access control in BookStack before v24.05.1 allows attackers to confirm existing system users and perform targeted notification email DoS via public facing forms.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pj36-fcrg-327j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-36676 Advisory: BookStack Incorrect Access Control vulnerability IDs: CVE-2024-36676, GHSA-pj36-fcrg-327j Record: https://patchnext.com/advisories/cve-2024-36676 (revision 1, source checked 26 Oct 2026, 14:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ssddanbrown/bookstack 24.05.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ssddanbrown/bookstack: affected < 24.05.1; fixed in 24.05.1 ## Suggested inspection (read-only) - Packagist ssddanbrown/bookstack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ssddanbrown/bookstack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pj36-fcrg-327j (GitHub-reviewed advisory GHSA-pj36-fcrg-327j lists affected ranges: Packagist ssddanbrown/bookstack >=0 <24.05.1) Commands are suggestions: review each one before running it.
Loading voting…