Skip to content

← Actionable
Critical, CVSS 9.8

GeoTools Remote Code Execution (RCE) vulnerability in evaluating XPath expressions

CVE-2024-36404GHSA-w3pj-wh35-fq8w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geotools:gt-app-schema 31.2, 30.4, 29.6, 28.6; org.geotools.xsd:gt-xsd-core 31.2, 30.4, 29.6, 28.6; org.geotools:gt-complex 31.2, 30.4, 29.6, 28.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-w3pj-wh35-fq8w lists affected ranges: Maven org.geotools:gt-app-schema >=30.0 =31.0 =29.0 =0 =30.0 =31.0 =29.0 =0 =30.0 =31.0 =29.0 =0 <28.6

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-36404: 76.06% estimated exploitation activity in the next 30 days; percentile 99.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Remote Code Execution (RCE) is possible if an application uses certain GeoTools functionality to evaluate XPath expressions supplied by user input. Details The following methods pass XPath expressions to the commons-jxpath library which can execute arbitrary code and would be a security issue if the XPath expressions are provided by user input. org.geotools.appschema.util.XmlXpathUtilites.getXPathValues(NamespaceSupport, String, Document) org.geotools.appschema.util.XmlXpathUtilites.countXPathNodes(NamespaceSupport, String, Document) org.geotools.appschema.util.XmlXpathUtilites.getSingleXPathValue(NamespaceSupport, String, Document) org.geotools.data.complex.expression.FeaturePropertyAccessorFactory.FeaturePropertyAccessor.get(Object, String, Class<T) org.geotools.data.complex.expression.FeaturePropertyAccessorFactory.FeaturePropertyAccessor.set(Object, String, Object, Class) org.geotools.data.complex.expression.MapPropertyAccessorFactory.new PropertyAccessor()…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w3pj-wh35-fq8w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-36404

Advisory: GeoTools Remote Code Execution (RCE) vulnerability in evaluating XPath expressions
IDs: CVE-2024-36404, GHSA-w3pj-wh35-fq8w
Record: https://patchnext.com/advisories/cve-2024-36404 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.geotools:gt-app-schema 31.2, 30.4, 29.6, 28.6; org.geotools.xsd:gt-xsd-core 31.2, 30.4, 29.6, 28.6; org.geotools:gt-complex 31.2, 30.4, 29.6, 28.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.geotools:gt-app-schema: affected >= 30.0, < 30.4; >= 31.0, < 31.2; >= 29.0, < 29.6; < 28.6; fixed in 28.6, 30.4, 31.2, 29.6
- Maven org.geotools.xsd:gt-xsd-core: affected >= 30.0, < 30.4; >= 31.0, < 31.2; >= 29.0, < 29.6; < 28.6; fixed in 28.6, 30.4, 31.2, 29.6
- Maven org.geotools:gt-complex: affected >= 30.0, < 30.4; >= 31.0, < 31.2; >= 29.0, < 29.6; < 28.6; fixed in 28.6, 30.4, 31.2, 29.6

## Suggested inspection (read-only)
- Maven org.geotools:gt-app-schema: check the installed version with your package manager.
- Maven org.geotools.xsd:gt-xsd-core: check the installed version with your package manager.
- Maven org.geotools:gt-complex: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.geotools:gt-app-schema, org.geotools.xsd:gt-xsd-core, org.geotools:gt-complex.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w3pj-wh35-fq8w (GitHub-reviewed advisory GHSA-w3pj-wh35-fq8w lists affected ranges: Maven org.geotools:gt-app-schema >=30.0 =31.0 =29.0 =0 =30.0 =31.0 =29.0 =0 =30.0 =31.0 =29.0 =0 <28.6)

Commands are suggestions: review each one before running it.

Loading voting…