Remote Code Execution (RCE) vulnerability in geoserver
CVE-2024-36401GHSA-6jj6-gm7p-fcvv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver:gs-wfs 2.25.2, 2.24.4, 2.23.6, 2.22.6; org.geoserver.web:gs-web-app 2.25.2, 2.24.4, 2.23.6, 2.22.6; org.geoserver:gs-wms 2.25.2, 2.24.4, 2.23.6, 2.22.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geoserver:gs-wfs
- Affected
- >= 2.24.0, < 2.24.4>= 2.25.0, < 2.25.2>= 2.23.0, < 2.23.6< 2.22.6
- Fixed in
- 2.22.6, 2.23.6, 2.24.4, 2.25.2
Maven org.geoserver.web:gs-web-app
- Affected
- >= 2.24.0, < 2.24.4>= 2.25.0, < 2.25.2>= 2.23.0, < 2.23.6< 2.22.6
- Fixed in
- 2.22.6, 2.23.6, 2.24.4, 2.25.2
Maven org.geoserver:gs-wms
- Affected
- >= 2.24.0, < 2.24.4>= 2.25.0, < 2.25.2>= 2.23.0, < 2.23.6< 2.22.6
- Fixed in
- 2.22.6, 2.23.6, 2.24.4, 2.25.2
Sources
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2024-36401 to the Known Exploited Vulnerabilities catalog on 2024-07-15.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2024-07-15).
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6jj6-gm7p-fcvv lists affected ranges: Maven org.geoserver.web:gs-web-app >=2.24.0 =2.25.0 =2.23.0 =0 =2.24.0 =2.25.0 =2.23.0 =0 =2.24.0 =2.25.0 =2.23.0 =0 <2.22.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A · score source
- EPSS
- CVE-2024-36401: 99.81% estimated exploitation activity in the next 30 days; percentile 99.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Multiple OGC request parameters allow Remote Code Execution (RCE) by unauthenticated users through specially crafted input against a default GeoServer installation due to unsafely evaluating property names as XPath expressions. Details The GeoTools library API that GeoServer calls evaluates property/attribute names for feature types in a way that unsafely passes them to the commons-jxpath library which can execute arbitrary code when evaluating XPath expressions. This XPath evaluation is intended to be used only by complex feature types (i.e., Application Schema data stores) but is incorrectly being applied to simple feature types as well which makes this vulnerability apply to ALL GeoServer instances. PoC No public PoC is provided but this vulnerability has been confirmed to be exploitable through WFS GetFeature, WFS GetPropertyValue, WMS GetMap, WMS GetFeatureInfo, WMS GetLegendGraphic and WPS Execute requests. Impact This vulnerability can lead to executing arbitrary code.…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6jj6-gm7p-fcvv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-36401 Advisory: Remote Code Execution (RCE) vulnerability in geoserver IDs: CVE-2024-36401, GHSA-6jj6-gm7p-fcvv Record: https://patchnext.com/advisories/cve-2024-36401 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: org.geoserver:gs-wfs 2.25.2, 2.24.4, 2.23.6, 2.22.6; org.geoserver.web:gs-web-app 2.25.2, 2.24.4, 2.23.6, 2.22.6; org.geoserver:gs-wms 2.25.2, 2.24.4, 2.23.6, 2.22.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geoserver:gs-wfs: affected >= 2.24.0, < 2.24.4; >= 2.25.0, < 2.25.2; >= 2.23.0, < 2.23.6; < 2.22.6; fixed in 2.22.6, 2.23.6, 2.24.4, 2.25.2 - Maven org.geoserver.web:gs-web-app: affected >= 2.24.0, < 2.24.4; >= 2.25.0, < 2.25.2; >= 2.23.0, < 2.23.6; < 2.22.6; fixed in 2.22.6, 2.23.6, 2.24.4, 2.25.2 - Maven org.geoserver:gs-wms: affected >= 2.24.0, < 2.24.4; >= 2.25.0, < 2.25.2; >= 2.23.0, < 2.23.6; < 2.22.6; fixed in 2.22.6, 2.23.6, 2.24.4, 2.25.2 ## Suggested inspection (read-only) - Maven org.geoserver:gs-wfs: check the installed version with your package manager. - Maven org.geoserver.web:gs-web-app: check the installed version with your package manager. - Maven org.geoserver:gs-wms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geoserver:gs-wfs, org.geoserver.web:gs-web-app, org.geoserver:gs-wms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2024-36401 to the Known Exploited Vulnerabilities catalog on 2024-07-15.) - Verified: https://github.com/advisories/GHSA-6jj6-gm7p-fcvv (GitHub-reviewed advisory GHSA-6jj6-gm7p-fcvv lists affected ranges: Maven org.geoserver.web:gs-web-app >=2.24.0 =2.25.0 =2.23.0 =0 =2.24.0 =2.25.0 =2.23.0 =0 =2.24.0 =2.25.0 =2.23.0 =0 <2.22.6) Commands are suggestions: review each one before running it.
Loading voting…