Pug allows JavaScript code execution if an application accepts untrusted input
CVE-2024-36361GHSA-3965-hpx2-q597
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pug 3.0.3; pug-code-gen 3.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pug
- Affected
- <= 3.0.2
- Fixed in
- 3.0.3
npm pug-code-gen
- Affected
- <= 3.0.2
- Fixed in
- 3.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3965-hpx2-q597 lists affected ranges: npm pug-code-gen >=0 =0 <3.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3965-hpx2-q597 lists affected ranges: npm pug >=0 =0 <=3.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-36361: 0.49% estimated exploitation activity in the next 30 days; percentile 42.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Pug through 3.0.2 allows JavaScript code execution if an application accepts untrusted input for the name option of the compileClient, compileFileClient, or compileClientWithDependenciesTracked function. NOTE: these functions are for compiling Pug templates into JavaScript, and there would typically be no reason to allow untrusted callers.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-3965-hpx2-q597
- Revision 1 · created ·
Published from osv record GHSA-3965-hpx2-q597
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-36361 Advisory: Pug allows JavaScript code execution if an application accepts untrusted input IDs: CVE-2024-36361, GHSA-3965-hpx2-q597 Record: https://patchnext.com/advisories/cve-2024-36361 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pug 3.0.3; pug-code-gen 3.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pug: affected <= 3.0.2; fixed in 3.0.3 - npm pug-code-gen: affected <= 3.0.2; fixed in 3.0.3 ## Suggested inspection (read-only) - `npm ls pug --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls pug-code-gen --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pug, pug-code-gen. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3965-hpx2-q597 (OSV record GHSA-3965-hpx2-q597 lists affected ranges: npm pug-code-gen >=0 =0 <3.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-3965-hpx2-q597 (GitHub-reviewed advisory GHSA-3965-hpx2-q597 lists affected ranges: npm pug >=0 =0 <=3.0.2) Commands are suggestions: review each one before running it.
Loading voting…