Skip to content

← Actionable
High, CVSS 8.2

Denial of Service via Zip/Decompression Bomb sent over HTTP or gRPC

CVE-2024-36129GHSA-c74f-6mfw-mm4v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (go.opentelemetry.io/collector/config/configgrpc 0.102.1; go.opentelemetry.io/collector/config/confighttp 0.102.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2024-36129: 1.24% estimated exploitation activity in the next 30 days; percentile 69.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary An unsafe decompression vulnerability allows unauthenticated attackers to crash the collector via excessive memory consumption. Details The OpenTelemetry Collector handles compressed HTTP requests by recognizing the Content-Encoding header, rewriting the HTTP request body, and allowing subsequent handlers to process decompressed data. It supports the gzip, zstd, zlib, snappy, and deflate compression algorithms. A "zip bomb" or "decompression bomb" is a malicious archive designed to crash or disable the system reading it. Decompression of HTTP requests is typically not enabled by default in popular server solutions due to associated security risks. A malicious attacker could leverage this weakness to crash the collector by sending a small request that, when uncompressed by the server, results in excessive memory consumption. During proof-of-concept (PoC) testing, all supported compression algorithms could be abused, with zstd causing the most significant impact. Compressing…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c74f-6mfw-mm4v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-36129

Advisory: Denial of Service via Zip/Decompression Bomb sent over HTTP or gRPC
IDs: CVE-2024-36129, GHSA-c74f-6mfw-mm4v
Record: https://patchnext.com/advisories/cve-2024-36129 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: go.opentelemetry.io/collector/config/configgrpc 0.102.1; go.opentelemetry.io/collector/config/confighttp 0.102.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go go.opentelemetry.io/collector/config/configgrpc: affected < 0.102.1; fixed in 0.102.1
- Go go.opentelemetry.io/collector/config/confighttp: affected < 0.102.0; fixed in 0.102.0

## Suggested inspection (read-only)
- Go go.opentelemetry.io/collector/config/configgrpc: check the installed version with your package manager.
- Go go.opentelemetry.io/collector/config/confighttp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on go.opentelemetry.io/collector/config/configgrpc, go.opentelemetry.io/collector/config/confighttp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c74f-6mfw-mm4v (GitHub-reviewed advisory GHSA-c74f-6mfw-mm4v lists affected ranges: Go go.opentelemetry.io/collector/config/confighttp >=0 =0 <0.102.1)

Commands are suggestions: review each one before running it.

Loading voting…