Skip to content

← Actionable
High, CVSS 7.5

apko Exposure of HTTP basic auth credentials in log output

CVE-2024-36127GHSA-v6mg-7f7p-qmqp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (chainguard.dev/apko 0.14.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-36127: 0.44% estimated exploitation activity in the next 30 days; percentile 38.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Exposure of HTTP basic auth credentials from repository and keyring URLs in log output Details There was a handful of instances where the apko tool was outputting error messages and log entries where HTTP basic authentication credentials were exposed for one of two reasons: 1. The%s verb was used to format a url.URL as a string, which includes un-redacted HTTP basic authentication credentials if they are included in the URL. 2. A string URL value (such as from the configuration YAML file supplied used in an apko execution) was never parsed as a URL, so there was no chance of redacting credentials in the logical flow. apko, as well as its companion library go-apk, have been updated to ensure URLs are parsed and redacted before being output as string values. PoC Create a config file like this apko.yaml: Then run: Observe instances of the password being shown verbatim in the log output, such as: Impact For users accessing keyring or APK repository content using HTTP basic auth,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v6mg-7f7p-qmqp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-36127

Advisory: apko Exposure of HTTP basic auth credentials in log output
IDs: CVE-2024-36127, GHSA-v6mg-7f7p-qmqp
Record: https://patchnext.com/advisories/cve-2024-36127 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: chainguard.dev/apko 0.14.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go chainguard.dev/apko: affected < 0.14.5; fixed in 0.14.5

## Suggested inspection (read-only)
- Go chainguard.dev/apko: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on chainguard.dev/apko.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v6mg-7f7p-qmqp (GitHub-reviewed advisory GHSA-v6mg-7f7p-qmqp lists affected ranges: Go chainguard.dev/apko >=0 <0.14.5)

Commands are suggestions: review each one before running it.

Loading voting…