Skip to content

← Actionable
High, CVSS 7.7

Reposilite artifacts vulnerable to Stored Cross-site Scripting

CVE-2024-36115GHSA-9w8w-34vr-65j2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.reposilite:reposilite-backend 3.5.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.7 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-36115: 0.83% estimated exploitation activity in the next 30 days; percentile 57.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Reposilite v3.5.10 is affected by Stored Cross-Site Scripting (XSS) when displaying artifact's content in the browser. Details As a Maven repository manager, Reposilite provides the ability to view the artifacts content in the browser, as well as perform administrative tasks via API. The problem lies in the fact that the artifact's content is served via the same origin (protocol/host/port) as the Admin UI. If the artifact contains HTML content with javascript inside, the javascript is executed within the same origin. Therefore, if an authenticated user is viewing the artifacts content, the javascript inside can access the browser's local storage where the user's password (aka 'token-secret') is stored. It is especially dangerous in scenarios where Reposilite is configured to mirror third party repositories, like the Maven Central Repository. Since anyone can publish an artifact to Maven Central under its own name, such malicious packages can be used to attack the Reposilite…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9w8w-34vr-65j2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-36115

Advisory: Reposilite artifacts vulnerable to Stored Cross-site Scripting
IDs: CVE-2024-36115, GHSA-9w8w-34vr-65j2
Record: https://patchnext.com/advisories/cve-2024-36115 (revision 1, source checked 26 Oct 2026, 16:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.reposilite:reposilite-backend 3.5.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.reposilite:reposilite-backend: affected >= 3.3.0, < 3.5.12; fixed in 3.5.12

## Suggested inspection (read-only)
- Maven com.reposilite:reposilite-backend: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.reposilite:reposilite-backend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9w8w-34vr-65j2 (GitHub-reviewed advisory GHSA-9w8w-34vr-65j2 lists affected ranges: Maven com.reposilite:reposilite-backend >=3.3.0 <3.5.12)

Commands are suggestions: review each one before running it.

Loading voting…