ansibleguy-webui Cross-site Scripting vulnerability
CVE-2024-36110GHSA-927p-xrc2-x2gj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ansibleguy-webui 0.0.21), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ansibleguy-webui
- Affected
- < 0.0.21
- Fixed in
- 0.0.21
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-927p-xrc2-x2gj lists affected ranges: PyPI ansibleguy-webui >=0 <0.0.21 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-927p-xrc2-x2gj lists affected ranges: PyPI ansibleguy-webui >=0 <0.0.21
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:L
- EPSS
- CVE-2024-36110: 0.40% estimated exploitation activity in the next 30 days; percentile 34.62 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Multiple forms in version <0.0.21 allowed injection of HTML elements. These are returned to the user after executing job actions and thus evaluated by the browser. Patches We recommend to upgrade to version = 0.0.21 References Report GitHub Issue 44
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-927p-xrc2-x2gj
- Revision 1 · created ·
Published from osv record GHSA-927p-xrc2-x2gj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-36110 Advisory: ansibleguy-webui Cross-site Scripting vulnerability IDs: CVE-2024-36110, GHSA-927p-xrc2-x2gj Record: https://patchnext.com/advisories/cve-2024-36110 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ansibleguy-webui 0.0.21. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ansibleguy-webui: affected < 0.0.21; fixed in 0.0.21 ## Suggested inspection (read-only) - `python -m pip show ansibleguy-webui`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ansibleguy-webui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-927p-xrc2-x2gj (OSV record GHSA-927p-xrc2-x2gj lists affected ranges: PyPI ansibleguy-webui >=0 <0.0.21 (fixed)) - Verified: https://github.com/advisories/GHSA-927p-xrc2-x2gj (GitHub-reviewed advisory GHSA-927p-xrc2-x2gj lists affected ranges: PyPI ansibleguy-webui >=0 <0.0.21) Commands are suggestions: review each one before running it.
Loading voting…