Skip to content

← Actionable
Medium, CVSS 5.3amended

dbt allows Binding to an Unrestricted IP Address via socketsocket

CVE-2024-36105GHSA-pmrx-695r-4349

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbt-core 1.8.1, 1.7.15, 1.6.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI dbt-core

    Affected
    < 1.6.15>= 1.7.0, < 1.7.15>= 1.8.0, <= 1.8.0
    Fixed in
    1.7.15, 1.6.15, 1.8.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-36105: 0.71% estimated exploitation activity in the next 30 days; percentile 53.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Binding to INADDRANY (0.0.0.0) or IN6ADDRANY (::) exposes an application on all network interfaces, increasing the risk of unauthorized access. While doing some static analysis and code inspection, I found the following code binding a socket to INADDRANY by passing "" as the address. This effectively binds to any network interface on the local system, not just localhost (127.0.0.1). Details As stated in the Python docs, a special form for address is accepted instead of a host address: '' represents INADDRANY, equivalent to "0.0.0.0". On systems with IPv6, '' represents IN6ADDRANY, which is equivalent to "::". https://github.com/dbt-labs/dbt-core/blob/main/core/dbt/task/docs/serve.py#L23C38-L23C39 The text around this code also imply the intention is to host docs only on localhost. PoC To recreate, run the docs ServeTask.run() to stand up the HTTP server. Then run netstat to see what addresses this process is bound. Impact A user who serves docs on an unsecured public network,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pmrx-695r-4349

  2. Revision 1 · created ·

    Published from osv record GHSA-pmrx-695r-4349

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-36105

Advisory: dbt allows Binding to an Unrestricted IP Address via socketsocket
IDs: CVE-2024-36105, GHSA-pmrx-695r-4349
Record: https://patchnext.com/advisories/cve-2024-36105 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dbt-core 1.8.1, 1.7.15, 1.6.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI dbt-core: affected < 1.6.15; >= 1.7.0, < 1.7.15; >= 1.8.0, <= 1.8.0; fixed in 1.7.15, 1.6.15, 1.8.1

## Suggested inspection (read-only)
- `python -m pip show dbt-core`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dbt-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pmrx-695r-4349 (OSV record GHSA-pmrx-695r-4349 lists affected ranges: PyPI dbt-core >=0 =1.7.0 =1.8.0 <1.8.1 (fixed))
- Verified: https://github.com/advisories/GHSA-pmrx-695r-4349 (GitHub-reviewed advisory GHSA-pmrx-695r-4349 lists affected ranges: PyPI dbt-core >=0 =1.7.0 =1.8.0 <=1.8.0)

Commands are suggestions: review each one before running it.

Loading voting…