Skip to content

← Actionable
Medium, CVSS 6.5amended

langchain vulnerable to path traversal

CVE-2024-3571GHSA-rgp8-pm28-3759

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (langchain 0.0.353), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI langchain

    Affected
    < 0.0.353
    Fixed in
    0.0.353

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-3571: 1.87% estimated exploitation activity in the next 30 days; percentile 79.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

langchain-ai/langchain is vulnerable to path traversal due to improper limitation of a pathname to a restricted directory ('Path Traversal') in its LocalFileStore functionality. An attacker can leverage this vulnerability to read or write files anywhere on the filesystem, potentially leading to information disclosure or remote code execution. The issue lies in the handling of file paths in the mset and mget methods, where user-supplied input is not adequately sanitized, allowing directory traversal sequences to reach unintended directories.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rgp8-pm28-3759

  2. Revision 1 · created ·

    Published from osv record GHSA-rgp8-pm28-3759

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-3571

Advisory: langchain vulnerable to path traversal
IDs: CVE-2024-3571, GHSA-rgp8-pm28-3759
Record: https://patchnext.com/advisories/cve-2024-3571 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: langchain 0.0.353. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI langchain: affected < 0.0.353; fixed in 0.0.353

## Suggested inspection (read-only)
- `python -m pip show langchain`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on langchain.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rgp8-pm28-3759 (OSV record GHSA-rgp8-pm28-3759 lists affected ranges: PyPI langchain >=0 <0.0.353 (fixed))
- Verified: https://github.com/advisories/GHSA-rgp8-pm28-3759 (GitHub-reviewed advisory GHSA-rgp8-pm28-3759 lists affected ranges: PyPI langchain >=0 <0.0.353)

Commands are suggestions: review each one before running it.

Loading voting…