Skip to content

← Actionable
Low, CVSS 3.4amended

Transformers Deserialization of Untrusted Data vulnerability

CVE-2024-3568GHSA-37q5-v5qm-c9v8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (transformers 4.38.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.4 · CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:N/A:L
EPSS
  • CVE-2024-3568: 2.08% estimated exploitation activity in the next 30 days; percentile 81.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The huggingface/transformers library is vulnerable to arbitrary code execution through deserialization of untrusted data within the loadrepocheckpoint() function of the TFPreTrainedModel() class. Attackers can execute arbitrary code and commands by crafting a malicious serialized payload, exploiting the use of pickle.load() on data from potentially untrusted sources. This vulnerability allows for remote code execution (RCE) by deceiving victims into loading a seemingly harmless checkpoint during a normal training process, thereby enabling attackers to execute arbitrary code on the targeted machine.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-37q5-v5qm-c9v8

  2. Revision 1 · created ·

    Published from osv record GHSA-37q5-v5qm-c9v8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-3568

Advisory: Transformers Deserialization of Untrusted Data vulnerability
IDs: CVE-2024-3568, GHSA-37q5-v5qm-c9v8
Record: https://patchnext.com/advisories/cve-2024-3568 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: transformers 4.38.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI transformers: affected < 4.38.0; fixed in 4.38.0

## Suggested inspection (read-only)
- `python -m pip show transformers`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on transformers.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-37q5-v5qm-c9v8 (OSV record GHSA-37q5-v5qm-c9v8 lists affected ranges: PyPI transformers >=0 <4.38.0 (fixed))
- Verified: https://github.com/advisories/GHSA-37q5-v5qm-c9v8 (GitHub-reviewed advisory GHSA-37q5-v5qm-c9v8 lists affected ranges: PyPI transformers >=0 <4.38.0)

Commands are suggestions: review each one before running it.

Loading voting…