Skip to content

← Actionable
Medium, CVSS 4.8

formwork Cross-site scripting vulnerability in Markdown fields

CVE-2024-35621GHSA-gx8m-f3mp-fg99

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getformwork/formwork 1.13.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-35621: 0.27% estimated exploitation activity in the next 30 days; percentile 19.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users with access to the administration panel with page editing permissions could insert <script tags in markdown fields, which are exposed on the publicly accessible site pages, leading to potential XSS injections. Patches - Formwork 1.13.0 has been released with a patch that solves this vulnerability. Now the system config option content.safemode (enabled by default) controls whether HTML tags and potentially dangerous links are escaped. This is configurable as in some cases more flexibility should be given. Panel users should be only a controlled group of editors, which cannot enable the option by themselves, and not a generic group. This mitigates the chance of introducing vulnerabilities. - Formwork 2.x (6adc302) adds a similar content.safeMode system option. Like Formwork 1.13.0, by default HTML tags and dangerous link are escaped. Even if enabled by an administrator, however, <script and other dangerous tags are still converted to text, but secure tags are allowed.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gx8m-f3mp-fg99

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-35621

Advisory: formwork Cross-site scripting vulnerability in Markdown fields
IDs: CVE-2024-35621, GHSA-gx8m-f3mp-fg99
Record: https://patchnext.com/advisories/cve-2024-35621 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getformwork/formwork 1.13.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getformwork/formwork: affected < 1.13.0; fixed in 1.13.0

## Suggested inspection (read-only)
- Packagist getformwork/formwork: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getformwork/formwork.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gx8m-f3mp-fg99 (GitHub-reviewed advisory GHSA-gx8m-f3mp-fg99 lists affected ranges: Packagist getformwork/formwork >=0 <1.13.0)

Commands are suggestions: review each one before running it.

Loading voting…