Tor Arti's STUB circuits incorrectly have a length of 2
CVE-2024-35312GHSA-9328-gcfq-p269
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (arti 1.2.3; tor-circmgr 0.18.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io arti
- Affected
- >= 1.2.2, <= 1.2.2
- Fixed in
- 1.2.3
crates.io tor-circmgr
- Affected
- >= 0.18.0, <= 0.18.0
- Fixed in
- 0.18.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9328-gcfq-p269 lists affected ranges: crates.io arti >=1.2.2 =0.18.0 <=0.18.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-35312: 0.19% estimated exploitation activity in the next 30 days; percentile 8.24 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Tor Arti before 1.2.3, STUB circuits incorrectly have a length of 2 (with lite vanguards), aka TROVE-2024-003.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9328-gcfq-p269
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-35312 Advisory: Tor Arti's STUB circuits incorrectly have a length of 2 IDs: CVE-2024-35312, GHSA-9328-gcfq-p269 Record: https://patchnext.com/advisories/cve-2024-35312 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: arti 1.2.3; tor-circmgr 0.18.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io arti: affected >= 1.2.2, <= 1.2.2; fixed in 1.2.3 - crates.io tor-circmgr: affected >= 0.18.0, <= 0.18.0; fixed in 0.18.1 ## Suggested inspection (read-only) - crates.io arti: check the installed version with your package manager. - crates.io tor-circmgr: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on arti, tor-circmgr. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9328-gcfq-p269 (GitHub-reviewed advisory GHSA-9328-gcfq-p269 lists affected ranges: crates.io arti >=1.2.2 =0.18.0 <=0.18.0) Commands are suggestions: review each one before running it.
Loading voting…