Skip to content

← Actionable
High, CVSS 8.6

rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming "profiler_runs" parameter

CVE-2024-35231GHSA-8c8q-2xw3-j869

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack-contrib 2.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
EPSS
  • CVE-2024-35231: 0.67% estimated exploitation activity in the next 30 days; percentile 51.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The next ruby code is vulnerable to denial of service due to the fact that the user controlled data profilerruns was not contrained to any limitation. Which would lead to allocating resources on the server side with no limitation (CWE-770). An exploit as such curl --fail "http://127.0.0.1:9292/?profilerruns=9999999999&profile=processtime" may cause resource exhaution by a remotely controlled value. PoC Herein the config.ru file: A Dockerfile: A Gemfile A Docker compose To run the PoC To exploit DoS: Impact - Potential denial of service by remotely user-controlled data.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8c8q-2xw3-j869

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-35231

Advisory: rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming "profiler_runs" parameter
IDs: CVE-2024-35231, GHSA-8c8q-2xw3-j869
Record: https://patchnext.com/advisories/cve-2024-35231 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rack-contrib 2.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rack-contrib: affected < 2.5.0; fixed in 2.5.0

## Suggested inspection (read-only)
- RubyGems rack-contrib: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rack-contrib.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8c8q-2xw3-j869 (GitHub-reviewed advisory GHSA-8c8q-2xw3-j869 lists affected ranges: RubyGems rack-contrib >=0 <2.5.0)

Commands are suggestions: review each one before running it.

Loading voting…