Smarty vulnerable to PHP Code Injection by malicious attribute in extends-tag
CVE-2024-35226GHSA-4rmg-292m-wg3w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (smarty/smarty 5.1.1, 4.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist smarty/smarty
- Affected
- >= 5.0.0, < 5.1.1>= 3.0.0, < 4.5.3
- Fixed in
- 4.5.3, 5.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4rmg-292m-wg3w lists affected ranges: Packagist smarty/smarty >=5.0.0 =3.0.0 <4.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-35226: 0.51% estimated exploitation activity in the next 30 days; percentile 43.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Template authors could inject php code by choosing a malicous file name for an extends-tag. Users that cannot fully trust template authors should update asap. Patches Please upgrade to the most recent version of Smarty v4 or v5. There is no patch for v3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4rmg-292m-wg3w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-35226 Advisory: Smarty vulnerable to PHP Code Injection by malicious attribute in extends-tag IDs: CVE-2024-35226, GHSA-4rmg-292m-wg3w Record: https://patchnext.com/advisories/cve-2024-35226 (revision 1, source checked 26 Oct 2026, 14:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: smarty/smarty 5.1.1, 4.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist smarty/smarty: affected >= 5.0.0, < 5.1.1; >= 3.0.0, < 4.5.3; fixed in 4.5.3, 5.1.1 ## Suggested inspection (read-only) - Packagist smarty/smarty: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on smarty/smarty. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4rmg-292m-wg3w (GitHub-reviewed advisory GHSA-4rmg-292m-wg3w lists affected ranges: Packagist smarty/smarty >=5.0.0 =3.0.0 <4.5.3) Commands are suggestions: review each one before running it.
Loading voting…