Jupyter Server Proxy has a reflected XSS issue in host parameter
CVE-2024-35225GHSA-fvcq-4x64-hqxr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server-proxy 4.2.0, 3.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server-proxy
- Affected
- >= 3.0.0, < 3.2.4>= 4.0.0, < 4.2.0
- Fixed in
- 4.2.0, 3.2.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fvcq-4x64-hqxr lists affected ranges: PyPI jupyter-server-proxy >=3.0.0 =4.0.0 <4.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fvcq-4x64-hqxr lists affected ranges: PyPI jupyter-server-proxy >=3.0.0 =4.0.0 <4.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- EPSS
- CVE-2024-35225: 0.45% estimated exploitation activity in the next 30 days; percentile 38.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a reflected cross-site scripting (XSS) issue in jupyter-server-proxy[1]. The /proxy endpoint accepts a host path segment in the format /proxy/<host. When this endpoint is called with an invalid host value, jupyter-server-proxy replies with a response that includes the value of host, without sanitization [2]. A third-party actor can leverage this by sending a phishing link with an invalid host value containing custom JavaScript to a user. When the user clicks this phishing link, the browser renders the response of GET /proxy/<host, which runs the custom JavaScript contained in host set by the actor. As any arbitrary JavaScript can be run after the user clicks on a phishing link, this issue permits extensive access to the user's JupyterLab instance for an actor. This issue exists in the latest release of jupyter-server-proxy, currently v4.1.2. Impacted versions: =3.0.0,<=4.1.2 Patches The patches are included in ==4.2.0 and ==3.2.4. Workarounds Server operators who are…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fvcq-4x64-hqxr
- Revision 1 · created ·
Published from osv record GHSA-fvcq-4x64-hqxr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-35225 Advisory: Jupyter Server Proxy has a reflected XSS issue in host parameter IDs: CVE-2024-35225, GHSA-fvcq-4x64-hqxr Record: https://patchnext.com/advisories/cve-2024-35225 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server-proxy 4.2.0, 3.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server-proxy: affected >= 3.0.0, < 3.2.4; >= 4.0.0, < 4.2.0; fixed in 4.2.0, 3.2.4 ## Suggested inspection (read-only) - `python -m pip show jupyter-server-proxy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server-proxy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fvcq-4x64-hqxr (OSV record GHSA-fvcq-4x64-hqxr lists affected ranges: PyPI jupyter-server-proxy >=3.0.0 =4.0.0 <4.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-fvcq-4x64-hqxr (GitHub-reviewed advisory GHSA-fvcq-4x64-hqxr lists affected ranges: PyPI jupyter-server-proxy >=3.0.0 =4.0.0 <4.2.0) Commands are suggestions: review each one before running it.
Loading voting…