Skip to content

← Actionable
Low, CVSS 2.0amended

Slack integration leaks sensitive information in logs

CVE-2024-35196GHSA-c2g2-gx4j-rj3j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sentry 24.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI sentry

    Affected
    >= 24.3.0, < 24.5.0
    Fixed in
    24.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.0 · CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2024-35196: 0.57% estimated exploitation activity in the next 30 days; percentile 47.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Sentry's Slack integration incorrectly records the incoming request body in logs. This request data can contain sensitive information, including the deprecated Slack verification token. With this verification token, it is possible under specific configurations, an attacker can forge requests and act as the Slack integration. The request body is leaked in log entries matching event == "slack." && name == "sentry.integrations.slack" && requestdata == . The deprecated slack verification token, will be found in the requestdata.token key. Example event: Patches - SaaS users do not need to take any action. - Self-hosted users should upgrade to version 24.5.0 or higher, rotate their Slack verification token, and use the Slack Signing Secret instead of the verification token. - If you are only using the slack.signing-secret in your self-hosted configuration, then the legacy verification token is not used to verify the webhook payload. It is ignored. ⚠️ Sentry's support for validating…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-c2g2-gx4j-rj3j

  2. Revision 1 · created ·

    Published from osv record GHSA-c2g2-gx4j-rj3j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-35196

Advisory: Slack integration leaks sensitive information in logs
IDs: CVE-2024-35196, GHSA-c2g2-gx4j-rj3j
Record: https://patchnext.com/advisories/cve-2024-35196 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sentry 24.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI sentry: affected >= 24.3.0, < 24.5.0; fixed in 24.5.0

## Suggested inspection (read-only)
- `python -m pip show sentry`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sentry.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-c2g2-gx4j-rj3j (OSV record GHSA-c2g2-gx4j-rj3j lists affected ranges: PyPI sentry >=24.3.0 <24.5.0 (fixed))
- Verified: https://github.com/advisories/GHSA-c2g2-gx4j-rj3j (GitHub-reviewed advisory GHSA-c2g2-gx4j-rj3j lists affected ranges: PyPI sentry >=24.3.0 <24.5.0)

Commands are suggestions: review each one before running it.

Loading voting…