Requests Session object does not verify requests after making first request with verify=False
CVE-2024-35195GHSA-9wx4-h78v-vm56
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (requests 2.32.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI requests
- Affected
- < 2.32.0
- Fixed in
- 2.32.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9wx4-h78v-vm56 lists affected ranges: PyPI requests >=0 <2.32.0
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9wx4-h78v-vm56 lists affected ranges: PyPI requests >=0 <2.32.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9wx4-h78v-vm56 lists affected ranges: PyPI requests >=0 <2.32.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.6 · CVSS:3.1/AV:L/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-35195: 0.34% estimated exploitation activity in the next 30 days; percentile 27.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using a requests.Session, if the first request to a given origin is made with verify=False, TLS certificate verification may remain disabled for all subsequent requests to that origin, even if verify=True is explicitly specified later. This occurs because the underlying connection is reused from the session's connection pool, causing the initial TLS verification setting to persist for the lifetime of the pooled connection. As a result, applications may unintentionally send requests without certificate verification, leading to potential man-in-the-middle attacks and compromised confidentiality or integrity. This behavior affects versions of requests prior to 2.32.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9wx4-h78v-vm56
- Revision 2 · amended ·
Amended from osv record GHSA-9wx4-h78v-vm56
- Revision 1 · created ·
Published from osv record GHSA-9wx4-h78v-vm56
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-35195 Advisory: Requests `Session` object does not verify requests after making first request with verify=False IDs: CVE-2024-35195, GHSA-9wx4-h78v-vm56 Record: https://patchnext.com/advisories/cve-2024-35195 (revision 3, source checked 26 Oct 2026, 13:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: requests 2.32.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI requests: affected < 2.32.0; fixed in 2.32.0 ## Suggested inspection (read-only) - `python -m pip show requests`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on requests. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9wx4-h78v-vm56 (OSV record GHSA-9wx4-h78v-vm56 lists affected ranges: PyPI requests >=0 <2.32.0) - Verified: https://osv.dev/vulnerability/GHSA-9wx4-h78v-vm56 (OSV record GHSA-9wx4-h78v-vm56 lists affected ranges: PyPI requests >=0 <2.32.0 (fixed)) - Verified: https://github.com/advisories/GHSA-9wx4-h78v-vm56 (GitHub-reviewed advisory GHSA-9wx4-h78v-vm56 lists affected ranges: PyPI requests >=0 <2.32.0) Commands are suggestions: review each one before running it.
Loading voting…