Trivy possibly leaks registry credential when scanning images from malicious registries
CVE-2024-35192GHSA-xcq4-m2r3-cmrj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/aquasecurity/trivy 0.51.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/aquasecurity/trivy
- Affected
- < 0.51.2
- Fixed in
- 0.51.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xcq4-m2r3-cmrj lists affected ranges: Go github.com/aquasecurity/trivy >=0 <0.51.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N
- EPSS
- CVE-2024-35192: 0.19% estimated exploitation activity in the next 30 days; percentile 8.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If a malicious actor is able to trigger Trivy to scan container images from a crafted malicious registry, it could result in the leakage of credentials for legitimate registries such as AWS Elastic Container Registry (ECR), Google Cloud Artifact/Container Registry, or Azure Container Registry (ACR). These tokens can then be used to push/pull images from those registries to which the identity/user running Trivy has access. Taking AWS as an example, the leakage only occurs when Trivy is able to transparently obtain registry credentials from the default credential provider chain. You are affected if Trivy is executed in any of the following situations: - The environment variables contain static AWS credentials (AWSACCESSKEYID, AWSSECRETACCESSKEY, AWSSESSIONTOKEN) that have access to ECR. - Within a Pod running on an EKS cluster that has been assigned a role with access to ECR using an IAM Roles for Service Accounts (IRSA) annotation. - etc. You are not affected if the default…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xcq4-m2r3-cmrj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-35192 Advisory: Trivy possibly leaks registry credential when scanning images from malicious registries IDs: CVE-2024-35192, GHSA-xcq4-m2r3-cmrj Record: https://patchnext.com/advisories/cve-2024-35192 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/aquasecurity/trivy 0.51.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/aquasecurity/trivy: affected < 0.51.2; fixed in 0.51.2 ## Suggested inspection (read-only) - Go github.com/aquasecurity/trivy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/aquasecurity/trivy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xcq4-m2r3-cmrj (GitHub-reviewed advisory GHSA-xcq4-m2r3-cmrj lists affected ranges: Go github.com/aquasecurity/trivy >=0 <0.51.2) Commands are suggestions: review each one before running it.
Loading voting…