verbb/formie Server-Side Template Injection for variable-enabled settings
CVE-2024-35191GHSA-v45m-hxqp-fwf5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (verbb/formie 2.1.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist verbb/formie
- Affected
- < 2.1.6
- Fixed in
- 2.1.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v45m-hxqp-fwf5 lists affected ranges: Packagist verbb/formie >=0 <2.1.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-35191: 0.25% estimated exploitation activity in the next 30 days; percentile 16.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Users with access to a form's settings can include malicious Twig code into fields that support Twig. These might be the Submission Title or the Success Message. This code will then be executed upon creating a submission, or rendering the text. This is listed as low-medium severity due to requiring control panel access to edit a form's settings. Patches This has been fixed in Formie 2.1.6. Users should ensure they are running at least this version.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v45m-hxqp-fwf5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-35191 Advisory: verbb/formie Server-Side Template Injection for variable-enabled settings IDs: CVE-2024-35191, GHSA-v45m-hxqp-fwf5 Record: https://patchnext.com/advisories/cve-2024-35191 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: verbb/formie 2.1.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist verbb/formie: affected < 2.1.6; fixed in 2.1.6 ## Suggested inspection (read-only) - Packagist verbb/formie: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on verbb/formie. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v45m-hxqp-fwf5 (GitHub-reviewed advisory GHSA-v45m-hxqp-fwf5 lists affected ranges: Packagist verbb/formie >=0 <2.1.6) Commands are suggestions: review each one before running it.
Loading voting…