Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints
CVE-2024-35189GHSA-rcvg-jj3g-rj7c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ethyca-fides 2.37.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ethyca-fides
- Affected
- < 2.37.0
- Fixed in
- 2.37.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rcvg-jj3g-rj7c lists affected ranges: PyPI ethyca-fides >=0 <2.37.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rcvg-jj3g-rj7c lists affected ranges: PyPI ethyca-fides >=0 <2.37.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-35189: 0.58% estimated exploitation activity in the next 30 days; percentile 47.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Fides webserver has a number of endpoints that retrieve ConnectionConfiguration records and their associated secrets which can contain sensitive data (e.g. passwords, private keys, etc.). These secrets are stored encrypted at rest (in the application database), and the associated endpoints are not meant to expose that sensitive data in plaintext to API clients, as it could be compromising. Fides's developers have available to them a Pydantic field-attribute (sensitive) that they can annotate as True to indicate that a given secret field should not be exposed via the API. The application has an internal function that uses sensitive annotations to mask the sensitive fields with a "" placeholder value. This vulnerability is due to a bug in that function, which prevented sensitive API model fields that were nested below the root-level of a secrets object from being masked appropriately. Only the BigQuery connection configuration secrets meets these criteria: the secrets schema has a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rcvg-jj3g-rj7c
- Revision 1 · created ·
Published from osv record GHSA-rcvg-jj3g-rj7c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-35189 Advisory: Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints IDs: CVE-2024-35189, GHSA-rcvg-jj3g-rj7c Record: https://patchnext.com/advisories/cve-2024-35189 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ethyca-fides 2.37.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ethyca-fides: affected < 2.37.0; fixed in 2.37.0 ## Suggested inspection (read-only) - `python -m pip show ethyca-fides`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ethyca-fides. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rcvg-jj3g-rj7c (OSV record GHSA-rcvg-jj3g-rj7c lists affected ranges: PyPI ethyca-fides >=0 <2.37.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rcvg-jj3g-rj7c (GitHub-reviewed advisory GHSA-rcvg-jj3g-rj7c lists affected ranges: PyPI ethyca-fides >=0 <2.37.0) Commands are suggestions: review each one before running it.
Loading voting…