Skip to content

← Actionable
Medium, CVSS 6.1amended

OMERO.web must check that the JSONP callback is a valid function

CVE-2024-35180GHSA-vr85-5pwx-c6gq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (omero-web 5.26.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2024-35180: 0.29% estimated exploitation activity in the next 30 days; percentile 21.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Background There is currently no escaping or validation of the callback parameter that can be passed to various OMERO.web endpoints that have JSONP enabled. One such endpoint is /webclient/imgData/.... As we only really use these endpoints with jQuery's own callback name generation [^1] it is quite difficult or even impossible to exploit this in vanilla OMERO.web. However, these metadata endpoints are likely to be used by many plugins. [^1]: https://learn.jquery.com/ajax/working-with-jsonp/ Impact OMERO.web before 5.25.0 Patches Users should upgrade to 5.26.0 or higher Workarounds None References https://stackoverflow.com/questions/2777021/do-i-need-to-sanitize-the-callback-parameter-from-a-jsonp-call https://stackoverflow.com/questions/1661197/what-characters-are-valid-for-javascript-variable-names For more information If you have any questions or comments about this advisory: Open an issue in omero-web Email us at security@openmicroscopy.org

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vr85-5pwx-c6gq

  2. Revision 1 · created ·

    Published from osv record GHSA-vr85-5pwx-c6gq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-35180

Advisory: OMERO.web must check that the JSONP callback is a valid function
IDs: CVE-2024-35180, GHSA-vr85-5pwx-c6gq
Record: https://patchnext.com/advisories/cve-2024-35180 (revision 2, source checked 26 Oct 2026, 13:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: omero-web 5.26.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI omero-web: affected < 5.26.0; fixed in 5.26.0

## Suggested inspection (read-only)
- `python -m pip show omero-web`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on omero-web.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vr85-5pwx-c6gq (OSV record GHSA-vr85-5pwx-c6gq lists affected ranges: PyPI omero-web >=0 <5.26.0 (fixed))
- Verified: https://github.com/advisories/GHSA-vr85-5pwx-c6gq (GitHub-reviewed advisory GHSA-vr85-5pwx-c6gq lists affected ranges: PyPI omero-web >=0 <5.26.0)

Commands are suggestions: review each one before running it.

Loading voting…