Apache Tomcat - Denial of Service
CVE-2024-34750GHSA-wm9w-rjj3-j356
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-coyote
- Affected
- >= 11.0.0-M1, < 11.0.0-M21>= 10.1.0-M1, < 10.1.25>= 9.0.0-M1, < 9.0.90>= 8.5.0, <= 8.5.100
- Fixed in
- 11.0.0-M21, 9.0.90, 10.1.25
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, < 11.0.0-M21>= 10.1.0-M1, < 10.1.25>= 9.0.0-M1, < 9.0.90>= 8.5.0, <= 8.5.100
- Fixed in
- 11.0.0-M21, 9.0.90, 10.1.25
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wm9w-rjj3-j356 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 <=8.5.100
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-34750: 4.60% estimated exploitation activity in the next 30 days; percentile 91.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Handling of Exceptional Conditions, Uncontrolled Resource Consumption vulnerability in Apache Tomcat. When processing an HTTP/2 stream, Tomcat did not handle some cases of excessive HTTP headers correctly. This led to a miscounting of active HTTP/2 streams which in turn led to the use of an incorrect infinite timeout which allowed connections to remain open which should have been closed. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M20, from 10.1.0-M1 through 10.1.24, from 9.0.0-M1 through 9.0.89. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Users are recommended to upgrade to version 11.0.0-M21, 10.1.25 or 9.0.90, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wm9w-rjj3-j356
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34750 Advisory: Apache Tomcat - Denial of Service IDs: CVE-2024-34750, GHSA-wm9w-rjj3-j356 Record: https://patchnext.com/advisories/cve-2024-34750 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-coyote 11.0.0-M21, 10.1.25, 9.0.90; org.apache.tomcat.embed:tomcat-embed-core 11.0.0-M21, 10.1.25, 9.0.90. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-coyote: affected >= 11.0.0-M1, < 11.0.0-M21; >= 10.1.0-M1, < 10.1.25; >= 9.0.0-M1, < 9.0.90; >= 8.5.0, <= 8.5.100; fixed in 11.0.0-M21, 9.0.90, 10.1.25 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.0-M21; >= 10.1.0-M1, < 10.1.25; >= 9.0.0-M1, < 9.0.90; >= 8.5.0, <= 8.5.100; fixed in 11.0.0-M21, 9.0.90, 10.1.25 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-coyote: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-coyote, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wm9w-rjj3-j356 (GitHub-reviewed advisory GHSA-wm9w-rjj3-j356 lists affected ranges: Maven org.apache.tomcat.embed:tomcat-embed-core >=11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0-M1 =8.5.0 <=8.5.100) Commands are suggestions: review each one before running it.
Loading voting…