Oceanic allows unsanitized user input to lead to path traversal in URLs
CVE-2024-34712GHSA-5h5v-hw44-f6gg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oceanic.js 1.10.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm oceanic.js
- Affected
- < 1.10.4
- Fixed in
- 1.10.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5h5v-hw44-f6gg lists affected ranges: npm oceanic.js >=0 <1.10.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5h5v-hw44-f6gg lists affected ranges: npm oceanic.js >=0 <1.10.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2024-34712: 0.56% estimated exploitation activity in the next 30 days; percentile 46.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Input to functions such as Client.rest.channels.removeBan is not url-encoded, resulting in specially crafted input such as ../../../channels/{id} being normalized into the url /api/v10/channels/{id}, and deleting a channel rather than removing a ban. Workarounds Sanitizing user input, ensuring strings are valid for the purpose they are being used for. Encoding input with encodeURIComponent before providing it to the library. References OceanicJS/Oceanic@8bf8ee8373b8c565fbdbf70a609aba4fbc1a1ffe
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5h5v-hw44-f6gg
- Revision 1 · created ·
Published from osv record GHSA-5h5v-hw44-f6gg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34712 Advisory: Oceanic allows unsanitized user input to lead to path traversal in URLs IDs: CVE-2024-34712, GHSA-5h5v-hw44-f6gg Record: https://patchnext.com/advisories/cve-2024-34712 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oceanic.js 1.10.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm oceanic.js: affected < 1.10.4; fixed in 1.10.4 ## Suggested inspection (read-only) - `npm ls oceanic.js --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oceanic.js. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5h5v-hw44-f6gg (OSV record GHSA-5h5v-hw44-f6gg lists affected ranges: npm oceanic.js >=0 <1.10.4 (fixed)) - Verified: https://github.com/advisories/GHSA-5h5v-hw44-f6gg (GitHub-reviewed advisory GHSA-5h5v-hw44-f6gg lists affected ranges: npm oceanic.js >=0 <1.10.4) Commands are suggestions: review each one before running it.
Loading voting…