GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF)
CVE-2024-34711GHSA-mc43-4fqr-c965
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver.main:gs-main 2.25.0; org.geoserver.web:gs-web-app 2.25.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geoserver.main:gs-main
- Affected
- < 2.25.0
- Fixed in
- 2.25.0
Maven org.geoserver.web:gs-web-app
- Affected
- < 2.25.0
- Fixed in
- 2.25.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mc43-4fqr-c965 lists affected ranges: Maven org.geoserver.web:gs-web-app >=0 =0 <2.25.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:N
- EPSS
- CVE-2024-34711: 0.30% estimated exploitation activity in the next 30 days; percentile 22.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An improper URI validation vulnerability exists that enables an unauthorized attacker to perform XML External Entities (XEE) attack, then send GET request to any HTTP server. Attacker can abuse this to scan internal networks and gain information about them then exploit further. Moreover, attacker can read limited .xsd file on system. Details By default, GeoServer use PreventLocalEntityResolver class from GeoTools to filter out malicious URIs in XML entities before resolving them. The URI must match the regex (?i)(jar:file|http|vfs)[^?#;]\\.xsd. But the regex leaves a chance for attackers to request to any HTTP server or limited file. Impact An unauthenticated attacker can: 1. Scan internal network to gain insight about it and exploit further. 2. SSRF to endpoint ends with .xsd. 3. Read limited .xsd file on system. Mitigation 1. Define the system property ENTITYRESOLUTIONALLOWLIST to limit the supported external schema locaitons. 2. The built-in allow list covers the locations…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mc43-4fqr-c965
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34711 Advisory: GeoServer has improper ENTITY_RESOLUTION_ALLOWLIST URI validation in XML Processing (SSRF) IDs: CVE-2024-34711, GHSA-mc43-4fqr-c965 Record: https://patchnext.com/advisories/cve-2024-34711 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geoserver.main:gs-main 2.25.0; org.geoserver.web:gs-web-app 2.25.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geoserver.main:gs-main: affected < 2.25.0; fixed in 2.25.0 - Maven org.geoserver.web:gs-web-app: affected < 2.25.0; fixed in 2.25.0 ## Suggested inspection (read-only) - Maven org.geoserver.main:gs-main: check the installed version with your package manager. - Maven org.geoserver.web:gs-web-app: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geoserver.main:gs-main, org.geoserver.web:gs-web-app. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mc43-4fqr-c965 (GitHub-reviewed advisory GHSA-mc43-4fqr-c965 lists affected ranges: Maven org.geoserver.web:gs-web-app >=0 =0 <2.25.0) Commands are suggestions: review each one before running it.
Loading voting…