Skip to content

← Actionable
Medium, CVSS 5.4amended

Directus Lacks Session Tokens Invalidation

CVE-2024-34709GHSA-g65h-35f3-x2w3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    >= 10.10.0, < 10.11.0
    Fixed in
    10.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
EPSS
  • CVE-2024-34709: 0.45% estimated exploitation activity in the next 30 days; percentile 39.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Currently session tokens function like the other JWT tokens where they are not actually invalidated when logging out. The directussession gets destroyed and the cookie gets deleted but if you captured the cookie value it will still work for the entire expiry time which is set to 1 day by default. Making it effectively a long lived unrevokable stateless token instead of the stateful session token it was meant to be. When authenticating a session token JWT, Directus should also check whether the associated directussession both still exists and has not expired (although the token should expire at the same time or before the session) to ensure leaked tokens are not valid indefinitely. Steps to reproduce - Copy the current session token from the cookie - Refresh and or log out - Use the saved session token to check if it is still valid Impact The lack of proper session expiration may improve the likely success of certain attacks. For example, a user might access a web site from a…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g65h-35f3-x2w3

  2. Revision 1 · created ·

    Published from osv record GHSA-g65h-35f3-x2w3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34709

Advisory: Directus Lacks Session Tokens Invalidation
IDs: CVE-2024-34709, GHSA-g65h-35f3-x2w3
Record: https://patchnext.com/advisories/cve-2024-34709 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 10.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected >= 10.10.0, < 10.11.0; fixed in 10.11.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g65h-35f3-x2w3 (OSV record GHSA-g65h-35f3-x2w3 lists affected ranges: npm directus >=10.10.0 <10.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-g65h-35f3-x2w3 (GitHub-reviewed advisory GHSA-g65h-35f3-x2w3 lists affected ranges: npm directus >=10.10.0 <10.11.0)

Commands are suggestions: review each one before running it.

Loading voting…