Skip to content

← Actionable
Medium, CVSS 4.9amended

Directus allows redacted data extraction on the API through "alias"

CVE-2024-34708GHSA-p8v3-m643-4xqx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 10.11.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    < 10.11.0
    Fixed in
    10.11.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.9 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2024-34708: 0.76% estimated exploitation activity in the next 30 days; percentile 55.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A user with permission to view any collection using redacted hashed fields can get access the raw stored version using the alias functionality on the API. Normally, these redacted fields will return however if we change the request to ?alias[workaround]=redacted we can instead retrieve the plain text value for the field. Steps to reproduce - Set up a simple role with read-access to users. - Create a new user with the role from the previous step - Assign a password to the user The easiest way to confirm this vulnerability is by first visiting /users/me. You should be presented with a redacted JSON-object. Next, visit /users/me?alias[hash]=password. This time, the returned JSON object will included the raw password hash instead of the redacted value. Workaround This can be avoided by removing permission to view the sensitive fields entirely from users or roles that should not be able to see them.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-p8v3-m643-4xqx

  2. Revision 1 · created ·

    Published from osv record GHSA-p8v3-m643-4xqx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34708

Advisory: Directus allows redacted data extraction on the API through "alias"
IDs: CVE-2024-34708, GHSA-p8v3-m643-4xqx
Record: https://patchnext.com/advisories/cve-2024-34708 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 10.11.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 10.11.0; fixed in 10.11.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-p8v3-m643-4xqx (OSV record GHSA-p8v3-m643-4xqx lists affected ranges: npm directus >=0 <10.11.0 (fixed))
- Verified: https://github.com/advisories/GHSA-p8v3-m643-4xqx (GitHub-reviewed advisory GHSA-p8v3-m643-4xqx lists affected ranges: npm directus >=0 <10.11.0)

Commands are suggestions: review each one before running it.

Loading voting…