Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages
CVE-2024-34707GHSA-r2hr-4v48-fjv3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nautobot 2.2.4, 1.6.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI nautobot
- Affected
- < 1.6.22>= 2.0.0, < 2.2.4
- Fixed in
- 2.2.4, 1.6.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r2hr-4v48-fjv3 lists affected ranges: PyPI nautobot >=0 =2.0.0 <2.2.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r2hr-4v48-fjv3 lists affected ranges: PyPI nautobot >=0 =2.0.0 <2.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:H/A:L
- EPSS
- CVE-2024-34707: 0.61% estimated exploitation activity in the next 30 days; percentile 49.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Nautobot user with admin privileges can modify the BANNERTOP, BANNERBOTTOM, and BANNERLOGIN configuration settings via the /admin/constance/config/ endpoint. Normally these settings are used to provide custom banner text at the top and bottom of all Nautobot web pages (or specifically on the login page in the case of BANNERLOGIN) but it was reported that an admin user can make use of these settings to inject arbitrary HTML, potentially exposing Nautobot users to security issues such as cross-site scripting (stored XSS). Patches Has the problem been patched? What versions should users upgrade to? Patches will be released as part of Nautobot 1.6.22 and 2.2.4. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? As described in the Nautobot documentation, these settings are only configurable through the admin UI of Nautobot if they are not explicitly set to some non-empty value in the nautobotconfig.py or equivalent Nautobot…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-r2hr-4v48-fjv3
- Revision 1 · created ·
Published from osv record GHSA-r2hr-4v48-fjv3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34707 Advisory: Nautobot's BANNER_* configuration can be used to inject arbitrary HTML content into Nautobot pages IDs: CVE-2024-34707, GHSA-r2hr-4v48-fjv3 Record: https://patchnext.com/advisories/cve-2024-34707 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nautobot 2.2.4, 1.6.22. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI nautobot: affected < 1.6.22; >= 2.0.0, < 2.2.4; fixed in 2.2.4, 1.6.22 ## Suggested inspection (read-only) - `python -m pip show nautobot`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nautobot. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r2hr-4v48-fjv3 (OSV record GHSA-r2hr-4v48-fjv3 lists affected ranges: PyPI nautobot >=0 =2.0.0 <2.2.4 (fixed)) - Verified: https://github.com/advisories/GHSA-r2hr-4v48-fjv3 (GitHub-reviewed advisory GHSA-r2hr-4v48-fjv3 lists affected ranges: PyPI nautobot >=0 =2.0.0 <2.2.4) Commands are suggestions: review each one before running it.
Loading voting…