Skip to content

← Actionable
Critical, CVSS 9.8amended

@valtimo/components exposes access token to form.io

CVE-2024-34706GHSA-xcp4-62vj-cq3r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@valtimo/components 11.2.2, 11.1.6, 10.8.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @valtimo/components

    Affected
    < 10.8.4>= 11.0.0, < 11.1.6>= 11.2.0, < 11.2.2
    Fixed in
    11.2.2, 11.1.6, 10.8.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2024-34706: 1.06% estimated exploitation activity in the next 30 days; percentile 64.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When opening a form in Valtimo, the access token (JWT) of the user is exposed to api.form.io via the the x-jwt-token header. An attacker can retrieve personal information from this token, or use it to execute requests to the Valtimo REST API on behalf of the logged-in user. This issue is caused by a misconfiguration of the Form.io component. Attack requirements

The following conditions have to be met in order to perform this attack: - An attacker needs to have access to the network traffic on the api.form.io domain. - The content of the x-jwt-token header is logged or otherwise available to the attacker. - An attacker needs to have network access to the Valtimo API. - An attacker needs to act within the time-to-live of the access token. The default TTL in Keycloak is 5 minutes. Patches Versions 10.8.4, 11.1.6 and 11.2.2 have been patched

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xcp4-62vj-cq3r

  2. Revision 1 · created ·

    Published from osv record GHSA-xcp4-62vj-cq3r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34706

Advisory: @valtimo/components exposes access token to form.io
IDs: CVE-2024-34706, GHSA-xcp4-62vj-cq3r
Record: https://patchnext.com/advisories/cve-2024-34706 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @valtimo/components 11.2.2, 11.1.6, 10.8.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @valtimo/components: affected < 10.8.4; >= 11.0.0, < 11.1.6; >= 11.2.0, < 11.2.2; fixed in 11.2.2, 11.1.6, 10.8.4

## Suggested inspection (read-only)
- `npm ls @valtimo/components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @valtimo/components.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xcp4-62vj-cq3r (OSV record GHSA-xcp4-62vj-cq3r lists affected ranges: npm @valtimo/components >=0 =11.0.0 =11.2.0 <11.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-xcp4-62vj-cq3r (GitHub-reviewed advisory GHSA-xcp4-62vj-cq3r lists affected ranges: npm @valtimo/components >=0 =11.0.0 =11.2.0 <11.2.2)

Commands are suggestions: review each one before running it.

Loading voting…