Skip to content

← Actionable
High, CVSS 8.1amended

LNbits improperly handles potential network and payment failures when using Eclair backend

CVE-2024-34694GHSA-3j4h-h3fp-vwww

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lnbits 0.12.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI lnbits

    Affected
    < 0.12.6
    Fixed in
    0.12.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2024-34694: 0.60% estimated exploitation activity in the next 30 days; percentile 48.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Paying invoices in Eclair that do not get settled within the internal timeout (about 30s) lead to a payment being considered failed, even though it may still be in flight. Details Using blocking: true on the API call will lead to a timeout error if a payment does not get settled in the 30s timeout with the error: Ask timed out on [Actor[akka://eclair-node/user/$l#134241942]] after [30000 ms]. Message of type [fr.acinq.eclair.payment.send.PaymentInitiator$SendPaymentToNode]. A typical reason for AskTimeoutException is that the recipient actor didn't send a reply. https://github.com/lnbits/lnbits/blob/c04c13b2f8cfbb625571a07dfddeb65ea6df8dac/lnbits/wallets/eclair.py#L138 This is considered a payment failure by parts of the code, and assumes the payment is not going to be settled after: https://github.com/lnbits/lnbits/blob/c04c13b2f8cfbb625571a07dfddeb65ea6df8dac/lnbits/wallets/eclair.py#L144…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3j4h-h3fp-vwww

  2. Revision 1 · created ·

    Published from osv record GHSA-3j4h-h3fp-vwww

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34694

Advisory: LNbits improperly handles potential network and payment failures when using Eclair backend
IDs: CVE-2024-34694, GHSA-3j4h-h3fp-vwww
Record: https://patchnext.com/advisories/cve-2024-34694 (revision 2, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lnbits 0.12.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI lnbits: affected < 0.12.6; fixed in 0.12.6

## Suggested inspection (read-only)
- `python -m pip show lnbits`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lnbits.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3j4h-h3fp-vwww (OSV record GHSA-3j4h-h3fp-vwww lists affected ranges: PyPI lnbits >=0 <0.12.6 (fixed))
- Verified: https://github.com/advisories/GHSA-3j4h-h3fp-vwww (GitHub-reviewed advisory GHSA-3j4h-h3fp-vwww lists affected ranges: PyPI lnbits >=0 <0.12.6)

Commands are suggestions: review each one before running it.

Loading voting…