Skip to content

← Actionable
Medium, CVSS 4.6amended

Apache Superset server arbitrary file read

CVE-2024-34693GHSA-hcr7-cqwc-q5gq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-superset 4.0.1, 3.1.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2024-34693: 1.58% estimated exploitation activity in the next 30 days; percentile 75.59 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Input Validation vulnerability in Apache Superset, allows for an authenticated attacker to create a MariaDB connection with localinfile enabled. If both the MariaDB server (off by default) and the local mysql client on the web server are set to allow for local infile, it's possible for the attacker to execute a specific MySQL/MariaDB SQL command that is able to read files from the server and insert their content on a MariaDB database table. This issue affects Apache Superset before version 3.1.3 and in version 4.0.0. Users are recommended to upgrade to version 4.0.1 or 3.1.3, both of which fix the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hcr7-cqwc-q5gq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hcr7-cqwc-q5gq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34693

Advisory: Apache Superset server arbitrary file read
IDs: CVE-2024-34693, GHSA-hcr7-cqwc-q5gq
Record: https://patchnext.com/advisories/cve-2024-34693 (revision 3, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-superset 4.0.1, 3.1.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-superset: affected < 3.1.3; >= 4.0.0, < 4.0.1; fixed in 3.1.3, 4.0.1

## Suggested inspection (read-only)
- `python -m pip show apache-superset`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-superset.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hcr7-cqwc-q5gq (OSV record GHSA-hcr7-cqwc-q5gq lists affected ranges: PyPI apache-superset >=0 =4.0.0 <4.0.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hcr7-cqwc-q5gq (GitHub-reviewed advisory GHSA-hcr7-cqwc-q5gq lists affected ranges: PyPI apache-superset >=0 =4.0.0 <4.0.1)

Commands are suggestions: review each one before running it.

Loading voting…