Neo4j Cypher component mishandles IMMUTABLE privileges
CVE-2024-34517GHSA-p343-9qwp-pqxv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.neo4j:neo4j-cypher 5.19.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.neo4j:neo4j-cypher
- Affected
- >= 5.0.0, < 5.19.0
- Fixed in
- 5.19.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p343-9qwp-pqxv lists affected ranges: Maven org.neo4j:neo4j-cypher >=5.0.0 <5.19.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2024-34517: 0.63% estimated exploitation activity in the next 30 days; percentile 50.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Cypher component in Neo4j between v.5.0.0 and v.5.19.0 mishandles IMMUTABLE.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p343-9qwp-pqxv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34517 Advisory: Neo4j Cypher component mishandles IMMUTABLE privileges IDs: CVE-2024-34517, GHSA-p343-9qwp-pqxv Record: https://patchnext.com/advisories/cve-2024-34517 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.neo4j:neo4j-cypher 5.19.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.neo4j:neo4j-cypher: affected >= 5.0.0, < 5.19.0; fixed in 5.19.0 ## Suggested inspection (read-only) - Maven org.neo4j:neo4j-cypher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.neo4j:neo4j-cypher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p343-9qwp-pqxv (GitHub-reviewed advisory GHSA-p343-9qwp-pqxv lists affected ranges: Maven org.neo4j:neo4j-cypher >=5.0.0 <5.19.0) Commands are suggestions: review each one before running it.
Loading voting…