image-optimizer allows PHAR deserialization
CVE-2024-34515GHSA-6pjm-hmvf-h4rr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spatie/image-optimizer 1.7.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist spatie/image-optimizer
- Affected
- < 1.7.3
- Fixed in
- 1.7.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6pjm-hmvf-h4rr lists affected ranges: Packagist spatie/image-optimizer >=0 <1.7.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-34515: 1.88% estimated exploitation activity in the next 30 days; percentile 79.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
image-optimizer before 1.7.3 allows PHAR deserialization, e.g., the phar:// protocol in arguments to fileexists().
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6pjm-hmvf-h4rr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34515 Advisory: image-optimizer allows PHAR deserialization IDs: CVE-2024-34515, GHSA-6pjm-hmvf-h4rr Record: https://patchnext.com/advisories/cve-2024-34515 (revision 1, source checked 26 Oct 2026, 14:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spatie/image-optimizer 1.7.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist spatie/image-optimizer: affected < 1.7.3; fixed in 1.7.3 ## Suggested inspection (read-only) - Packagist spatie/image-optimizer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spatie/image-optimizer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6pjm-hmvf-h4rr (GitHub-reviewed advisory GHSA-6pjm-hmvf-h4rr lists affected ranges: Packagist spatie/image-optimizer >=0 <1.7.3) Commands are suggestions: review each one before running it.
Loading voting…