Skip to content

← Actionable
High, CVSS 8.2

Previous ATX is not checked to be the newest valid ATX by Smesher when validating incoming ATX

CVE-2024-34360GHSA-jcqq-g64v-gcm7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/spacemeshos/go-spacemesh 1.5.2-hotfix1; github.com/spacemeshos/api 1.37.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
EPSS
  • CVE-2024-34360: 0.73% estimated exploitation activity in the next 30 days; percentile 54.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Nodes can publish ATXs which reference the incorrect previous ATX of the Smesher that created the ATX. ATXs are expected to form a single chain from the newest to the first ATX ever published by an identity. Allowing Smeshers to reference an earlier (but not the latest) ATX as previous breaks this protocol rule and can serve as an attack vector where Nodes are rewarded for holding their PoST data for less than one epoch but still being eligible for rewards. Patches - API needs to be extended to be able to fetch events from a node that dected malicious behavior of this regard by the node - go-spacemesh needs to be patched to a) not allow publishing these ATXs any more and b) create malfeasance proofs for identities that published invalid ATXs in the past. Workarounds n/a References Spacemesh protocol whitepaper: https://spacemesh.io/blog/spacemesh-white-paper-1/, specifically sections 4.4.2 ("ATX Contents") and 4.4.3 ("ATX validity")

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jcqq-g64v-gcm7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34360

Advisory: Previous ATX is not checked to be the newest valid ATX by Smesher when validating incoming ATX
IDs: CVE-2024-34360, GHSA-jcqq-g64v-gcm7
Record: https://patchnext.com/advisories/cve-2024-34360 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/spacemeshos/go-spacemesh 1.5.2-hotfix1; github.com/spacemeshos/api 1.37.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/spacemeshos/go-spacemesh: affected < 1.5.2-hotfix1; fixed in 1.5.2-hotfix1
- Go github.com/spacemeshos/api: affected < 1.37.1; fixed in 1.37.1

## Suggested inspection (read-only)
- Go github.com/spacemeshos/go-spacemesh: check the installed version with your package manager.
- Go github.com/spacemeshos/api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/spacemeshos/go-spacemesh, github.com/spacemeshos/api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jcqq-g64v-gcm7 (GitHub-reviewed advisory GHSA-jcqq-g64v-gcm7 lists affected ranges: Go github.com/spacemeshos/go-spacemesh >=0 =0 <1.37.1)

Commands are suggestions: review each one before running it.

Loading voting…