Skip to content

← Actionable
Low, CVSS 3.5

TYPO3 vulnerable to an HTML Injection in the History Module

CVE-2024-34355GHSA-xjwx-78x7-q6jc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 13.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
EPSS
  • CVE-2024-34355: 0.59% estimated exploitation activity in the next 30 days; percentile 48.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Problem The history backend module is vulnerable to HTML injection. Although Content-Security-Policy headers effectively prevent JavaScript execution, adversaries can still inject malicious HTML markup. Exploiting this vulnerability requires a valid backend user account. Solution Update to TYPO3 version 13.1.1 that fixes the problem described. Credits Thanks to TYPO3 core team member Andreas Kienast who reported this issue and to TYPO3 core & security team Benjamin Franzke who fixed the issue. References TYPO3-CORE-SA-2024-007

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xjwx-78x7-q6jc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34355

Advisory: TYPO3 vulnerable to an HTML Injection in the History Module
IDs: CVE-2024-34355, GHSA-xjwx-78x7-q6jc
Record: https://patchnext.com/advisories/cve-2024-34355 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 13.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected >= 13.0.0, <= 13.1.0; fixed in 13.1.1

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xjwx-78x7-q6jc (GitHub-reviewed advisory GHSA-xjwx-78x7-q6jc lists affected ranges: Packagist typo3/cms-core >=13.0.0 <=13.1.0)

Commands are suggestions: review each one before running it.

Loading voting…