Next.js Server-Side Request Forgery in Server Actions
CVE-2024-34351GHSA-fr5h-rqp8-mj6g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next 14.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next
- Affected
- >= 13.4.0, < 14.1.1
- Fixed in
- 14.1.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fr5h-rqp8-mj6g lists affected ranges: npm next >=13.4.0 <14.1.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fr5h-rqp8-mj6g lists affected ranges: npm next >=13.4.0 <14.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2024-34351: 5.45% estimated exploitation activity in the next 30 days; percentile 92.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Server-Side Request Forgery (SSRF) vulnerability was identified in Next.js Server Actions by security researchers at Assetnote. If the Host header is modified, and the below conditions are also met, an attacker may be able to make requests that appear to be originating from the Next.js application server itself. Prerequisites Next.js (<14.1.1) is running in a self-hosted manner. The Next.js application makes use of Server Actions. The Server Action performs a redirect to a relative path which starts with a /. \ Many hosting providers (including Vercel) route requests based on the Host header, so we do not believe that this vulnerability affects any Next.js applications where routing is done in this manner. Patches This vulnerability was patched in #62561 and fixed in Next.js 14.1.1. Workarounds There are no official workarounds for this vulnerability. We recommend upgrading to Next.js 14.1.1. Credit Vercel and the Next.js team thank Assetnote for responsibly disclosing this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fr5h-rqp8-mj6g
- Revision 1 · created ·
Published from osv record GHSA-fr5h-rqp8-mj6g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34351 Advisory: Next.js Server-Side Request Forgery in Server Actions IDs: CVE-2024-34351, GHSA-fr5h-rqp8-mj6g Record: https://patchnext.com/advisories/cve-2024-34351 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next 14.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next: affected >= 13.4.0, < 14.1.1; fixed in 14.1.1 ## Suggested inspection (read-only) - `npm ls next --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fr5h-rqp8-mj6g (OSV record GHSA-fr5h-rqp8-mj6g lists affected ranges: npm next >=13.4.0 <14.1.1 (fixed)) - Verified: https://github.com/advisories/GHSA-fr5h-rqp8-mj6g (GitHub-reviewed advisory GHSA-fr5h-rqp8-mj6g lists affected ranges: npm next >=13.4.0 <14.1.1) Commands are suggestions: review each one before running it.
Loading voting…