Skip to content

← Actionable
Medium, CVSS 4.8

Sylius potentially vulnerable to Cross Site Scripting via "Name" field (Taxons, Products, Options, Variants) in Admin Panel

CVE-2024-34349GHSA-v2f9-rv6w-vw8r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sylius/sylius 1.13.1, 1.12.16, 1.11.17, 1.10.16, 1.9.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist sylius/sylius

    Affected
    >= 1.12.0-alpha.1, < 1.12.16>= 1.13.0-alpha.1, < 1.13.1< 1.9.12>= 1.10.0-alpha.1, < 1.10.16>= 1.11.0-alpha.1, < 1.11.17
    Fixed in
    1.10.16, 1.11.17, 1.12.16, 1.9.12, 1.13.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-v2f9-rv6w-vw8r lists affected ranges: Packagist sylius/sylius >=1.12.0-alpha.1 =1.13.0-alpha.1 =0 =1.10.0-alpha.1 =1.11.0-alpha.1 <1.11.17

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2024-34349: 0.44% estimated exploitation activity in the next 30 days; percentile 37.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact There is a possibility to execute javascript code in the Admin panel. In order to perform an XSS attack input a script into Name field in which of the resources: Taxons, Products, Product Options or Product Variants. The code will be executed while using an autocomplete field with one of the listed entities in the Admin Panel. Also for the taxons in the category tree on the product form. Patches The issue is fixed in versions: 1.9.12, 1.10.16, 1.11.17, 1.12.16, 1.13.1 and above. Workarounds 1. Create a new file assets/admin/sylius-lazy-choice-tree.js: 2. Create new file assets/admin/sylius-auto-complete.js: 3. Create new file assets/admin/sylius-product-auto-complete.js: 4. Add new import in assets/admin/entry.js: 5. If you're using Gulp, update your gulpfile.babel.js: 6. Rebuild your assets: Acknowledgements This security issue has been reported by Checkmarx Research Group, thank you! For more information If you have any questions or comments about this advisory: Open an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-v2f9-rv6w-vw8r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34349

Advisory: Sylius potentially vulnerable to Cross Site Scripting via "Name" field (Taxons, Products, Options, Variants) in Admin Panel
IDs: CVE-2024-34349, GHSA-v2f9-rv6w-vw8r
Record: https://patchnext.com/advisories/cve-2024-34349 (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sylius/sylius 1.13.1, 1.12.16, 1.11.17, 1.10.16, 1.9.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist sylius/sylius: affected >= 1.12.0-alpha.1, < 1.12.16; >= 1.13.0-alpha.1, < 1.13.1; < 1.9.12; >= 1.10.0-alpha.1, < 1.10.16; >= 1.11.0-alpha.1, < 1.11.17; fixed in 1.10.16, 1.11.17, 1.12.16, 1.9.12, 1.13.1

## Suggested inspection (read-only)
- Packagist sylius/sylius: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sylius/sylius.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-v2f9-rv6w-vw8r (GitHub-reviewed advisory GHSA-v2f9-rv6w-vw8r lists affected ranges: Packagist sylius/sylius >=1.12.0-alpha.1 =1.13.0-alpha.1 =0 =1.10.0-alpha.1 =1.11.0-alpha.1 <1.11.17)

Commands are suggestions: review each one before running it.

Loading voting…