Skip to content

← Actionable
High, CVSS 8.4

Deno permission escalation vulnerability via open of privileged files with missing --deny flag

CVE-2024-34346GHSA-23rx-c3g5-hv9w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (deno 1.43.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io deno

    Affected
    < 1.43.1
    Fixed in
    1.43.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-34346: 0.37% estimated exploitation activity in the next 30 days; percentile 30.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Deno sandbox may be unexpectedly weakened by allowing file read/write access to privileged files in various locations on Unix and Windows platforms. For example, reading /proc/self/environ may provide access equivalent to --allow-env, and writing /proc/self/mem may provide access equivalent to --allow-all. Users who grant read and write access to the entire filesystem may not realize that these access to these files may have additional, unintended consequences. The documentation did not reflect that this practice should be undertaken to increase the strength of the security sandbox. Impact Users who run code with --allow-read or --allow-write may unexpectedly end up granting additional permissions via file-system operations. Patches Deno 1.43 and above require explicit --allow-all access to read or write /etc, /dev on unix platform (as well as /proc and /sys on linux platforms), and any path starting with \\ on Windows. Workarounds The security sandbox in previous versions of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-23rx-c3g5-hv9w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34346

Advisory: Deno permission escalation vulnerability via open of privileged files with missing `--deny` flag
IDs: CVE-2024-34346, GHSA-23rx-c3g5-hv9w
Record: https://patchnext.com/advisories/cve-2024-34346 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: deno 1.43.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io deno: affected < 1.43.1; fixed in 1.43.1

## Suggested inspection (read-only)
- crates.io deno: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on deno.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-23rx-c3g5-hv9w (GitHub-reviewed advisory GHSA-23rx-c3g5-hv9w lists affected ranges: crates.io deno >=0 <1.43.1)

Commands are suggestions: review each one before running it.

Loading voting…