Nuxt vulnerable to remote code execution via the browser when running the test locally
CVE-2024-34344GHSA-v784-fjjh-f8r4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nuxt 3.12.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm nuxt
- Affected
- >= 3.4.0, < 3.12.4
- Fixed in
- 3.12.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v784-fjjh-f8r4 lists affected ranges: npm nuxt >=3.4.0 <3.12.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v784-fjjh-f8r4 lists affected ranges: npm nuxt >=3.4.0 <3.12.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2024-34344: 0.83% estimated exploitation activity in the next 30 days; percentile 57.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Due to the insufficient validation of the path parameter in the NuxtTestComponentWrapper, an attacker can execute arbitrary JavaScript on the server side, which allows them to execute arbitrary commands. Details While running the test, a special component named NuxtTestComponentWrapper is available. https://github.com/nuxt/nuxt/blob/4779f5906fa4d3c784c2e2d6fe5a5c5f181faaec/packages/nuxt/src/app/components/nuxt-root.vue#L42-L43 This component loads the specified path as a component and renders it. https://github.com/nuxt/nuxt/blob/4779f5906fa4d3c784c2e2d6fe5a5c5f181faaec/packages/nuxt/src/app/components/test-component-wrapper.ts#L9-L27 There is a validation for the path parameter to check whether the path traversal is performed, but this check is not sufficient. https://github.com/nuxt/nuxt/blob/4779f5906fa4d3c784c2e2d6fe5a5c5f181faaec/packages/nuxt/src/app/components/test-component-wrapper.ts#L15-L19 Since import(...) uses query.path instead of the normalized path, a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-v784-fjjh-f8r4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-v784-fjjh-f8r4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34344 Advisory: Nuxt vulnerable to remote code execution via the browser when running the test locally IDs: CVE-2024-34344, GHSA-v784-fjjh-f8r4 Record: https://patchnext.com/advisories/cve-2024-34344 (revision 3, source checked 26 Oct 2026, 12:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nuxt 3.12.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nuxt: affected >= 3.4.0, < 3.12.4; fixed in 3.12.4 ## Suggested inspection (read-only) - `npm ls nuxt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nuxt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v784-fjjh-f8r4 (OSV record GHSA-v784-fjjh-f8r4 lists affected ranges: npm nuxt >=3.4.0 <3.12.4 (fixed)) - Verified: https://github.com/advisories/GHSA-v784-fjjh-f8r4 (GitHub-reviewed advisory GHSA-v784-fjjh-f8r4 lists affected ranges: npm nuxt >=3.4.0 <3.12.4) Commands are suggestions: review each one before running it.
Loading voting…