Magento Open Source affected by an Improper Restriction of XML External Entity Reference ('XXE') vulnerability
CVE-2024-34102GHSA-m8cj-3v68-3cxj
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist magento/community-edition
- Affected
- >= 2.4.4, <= 2.4.4>= 2.4.6-p1, < 2.4.6-p6>= 2.4.5-p1, < 2.4.5-p8< 2.4.4-p9>= 2.4.5, <= 2.4.5>= 2.4.6, <= 2.4.6>= 2.4.7, <= 2.4.7
- Fixed in
- 2.4.5-p8, 2.4.6-p6, 2.4.4-p9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m8cj-3v68-3cxj lists affected ranges: Packagist magento/community-edition >=2.4.4 =2.4.6-p1 =2.4.5-p1 =0 =2.4.5 =2.4.6 =2.4.7 <=2.4.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2024-34102 to the Known Exploited Vulnerabilities catalog on 2024-07-17.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2024-07-17).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-34102: 99.99% estimated exploitation activity in the next 30 days; percentile 99.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Adobe Commerce versions 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8 and earlier are affected by an Improper Restriction of XML External Entity Reference ('XXE') vulnerability that could result in arbitrary code execution. An attacker could exploit this vulnerability by sending a crafted XML document that references external entities. Exploitation of this issue does not require user interaction.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m8cj-3v68-3cxj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34102
Advisory: Magento Open Source affected by an Improper Restriction of XML External Entity Reference ('XXE') vulnerability
IDs: CVE-2024-34102, GHSA-m8cj-3v68-3cxj
Record: https://patchnext.com/advisories/cve-2024-34102 (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
Vendor response: Partial vendor fix; fixed versions by package: magento/community-edition 2.4.6-p6, 2.4.5-p8, 2.4.4-p9. A vendor fix does not mean a deployment is fixed.
## Affected components
- Packagist magento/community-edition: affected >= 2.4.4, <= 2.4.4; >= 2.4.6-p1, < 2.4.6-p6; >= 2.4.5-p1, < 2.4.5-p8; < 2.4.4-p9; >= 2.4.5, <= 2.4.5; >= 2.4.6, <= 2.4.6; >= 2.4.7, <= 2.4.7; fixed in 2.4.5-p8, 2.4.6-p6, 2.4.4-p9
## Suggested inspection (read-only)
- Packagist magento/community-edition: check the installed version with your package manager.
## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.
## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on magento/community-edition.
- Repeat the inspection and confirm that only fixed versions remain installed.
## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.
## Unresolved questions
- Which deployments run an affected version?
- Mark the work resolved only after the fixed version is verified in production.
## Sources
- Verified: https://github.com/advisories/GHSA-m8cj-3v68-3cxj (GitHub-reviewed advisory GHSA-m8cj-3v68-3cxj lists affected ranges: Packagist magento/community-edition >=2.4.4 =2.4.6-p1 =2.4.5-p1 =0 =2.4.5 =2.4.6 =2.4.7 <=2.4.7)
- Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2024-34102 to the Known Exploited Vulnerabilities catalog on 2024-07-17.)
Commands are suggestions: review each one before running it.Loading voting…