Skip to content

← Actionable
Medium, CVSS 6.6

Mantis Bug Tracker (MantisBT) vulnerable to cross-site scripting

CVE-2024-34081GHSA-wgx7-jp56-65mq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mantisbt/mantisbt 2.26.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L
EPSS
  • CVE-2024-34081: 0.64% estimated exploitation activity in the next 30 days; percentile 50.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper escaping of a custom field's name allows an attacker to inject HTML and, if CSP settings permit, achieve execution of arbitrary JavaScript when: - resolving or closing issues (bugchangestatuspage.php) belonging to a project linking said custom field - viewing issues (viewallbugpage.php) when the custom field is displayed as a column - printing issues (printallbugpage.php) when the custom field is displayed as a column Impact Cross-site scripting (XSS). Patches https://github.com/mantisbt/mantisbt/commit/447a521aae0f82f791b8116a14a20e276df739be Workarounds Ensure Custom Field Names do not contain HTML tags. References - https://mantisbt.org/bugs/view.php?id=34432 - This is related to CVE-2020-25830 (same root cause, different affected pages)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wgx7-jp56-65mq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34081

Advisory: Mantis Bug Tracker (MantisBT) vulnerable to cross-site scripting
IDs: CVE-2024-34081, GHSA-wgx7-jp56-65mq
Record: https://patchnext.com/advisories/cve-2024-34081 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mantisbt/mantisbt 2.26.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mantisbt/mantisbt: affected < 2.26.2; fixed in 2.26.2

## Suggested inspection (read-only)
- Packagist mantisbt/mantisbt: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mantisbt/mantisbt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wgx7-jp56-65mq (GitHub-reviewed advisory GHSA-wgx7-jp56-65mq lists affected ranges: Packagist mantisbt/mantisbt >=0 <2.26.2)

Commands are suggestions: review each one before running it.

Loading voting…