Skip to content

← Actionable
Critical, CVSS 9.6

Blind XSS Leading to Froxlor Application Compromise

CVE-2024-34070GHSA-x525-54hf-xr53

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (froxlor/froxlor 2.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-34070: 0.97% estimated exploitation activity in the next 30 days; percentile 61.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description: A Stored Blind Cross-Site Scripting (XSS) vulnerability has been identified in the Failed Login Attempts Logging Feature of the Froxlor Application. Stored Blind XSS occurs when user input is not properly sanitized and is stored on the server, allowing an attacker to inject malicious scripts that will be executed when other users access the affected page. In this case, an unauthenticated User can inject malicious scripts in the loginname parameter on the Login attempt, which will then be executed when viewed by the Administrator in the System Logs. The application protects users against XSS attacks by utilizing an xss sanitization library. But the checks of the library were bypassed by crafting an XSS Payload using data binding and interpolation of Vue.js A working XSS payload was crafted which forces an administrator to add a new malicious attacker-controlled Administrator User. The Payload is: payload.txt By exploiting this vulnerability, an unauthenticated attacker…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x525-54hf-xr53

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34070

Advisory: Blind XSS Leading to Froxlor Application Compromise
IDs: CVE-2024-34070, GHSA-x525-54hf-xr53
Record: https://patchnext.com/advisories/cve-2024-34070 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: froxlor/froxlor 2.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist froxlor/froxlor: affected < 2.1.9; fixed in 2.1.9

## Suggested inspection (read-only)
- Packagist froxlor/froxlor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on froxlor/froxlor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x525-54hf-xr53 (GitHub-reviewed advisory GHSA-x525-54hf-xr53 lists affected ranges: Packagist froxlor/froxlor >=0 <2.1.9)

Commands are suggestions: review each one before running it.

Loading voting…