Werkzeug debugger vulnerable to remote execution when interacting with attacker controlled domain
CVE-2024-34069GHSA-2g68-c3qc-8985
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (werkzeug 3.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI werkzeug
- Affected
- < 3.0.3
- Fixed in
- 3.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2g68-c3qc-8985 lists affected ranges: PyPI werkzeug >=0 <3.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2g68-c3qc-8985 lists affected ranges: PyPI werkzeug >=0 <3.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2024-34069: 3.40% estimated exploitation activity in the next 30 days; percentile 88.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The debugger in affected versions of Werkzeug can allow an attacker to execute code on a developer's machine under some circumstances. This requires the attacker to get the developer to interact with a domain and subdomain they control, and enter the debugger PIN, but if they are successful it allows access to the debugger even if it is only running on localhost. This also requires the attacker to guess a URL in the developer's application that will trigger the debugger.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2g68-c3qc-8985
- Revision 1 · created ·
Published from osv record GHSA-2g68-c3qc-8985
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34069 Advisory: Werkzeug debugger vulnerable to remote execution when interacting with attacker controlled domain IDs: CVE-2024-34069, GHSA-2g68-c3qc-8985 Record: https://patchnext.com/advisories/cve-2024-34069 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: werkzeug 3.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI werkzeug: affected < 3.0.3; fixed in 3.0.3 ## Suggested inspection (read-only) - `python -m pip show werkzeug`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on werkzeug. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2g68-c3qc-8985 (OSV record GHSA-2g68-c3qc-8985 lists affected ranges: PyPI werkzeug >=0 <3.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-2g68-c3qc-8985 (GitHub-reviewed advisory GHSA-2g68-c3qc-8985 lists affected ranges: PyPI werkzeug >=0 <3.0.3) Commands are suggestions: review each one before running it.
Loading voting…