Skip to content

← Actionable
High, CVSS 8.4

Pterodactyl Wings vulnerable to Arbitrary File Write/Read

CVE-2024-34066GHSA-gqmf-jqgv-v8fw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pterodactyl/wings 1.11.12), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2024-34066: 0.54% estimated exploitation activity in the next 30 days; percentile 45.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If the Wings token is leaked either by viewing the node configuration or posting it accidentally somewhere, an attacker can use it to gain arbitrary file write and read access on the node the token is associated to. Workarounds Enabling the ignorepanelconfigupdates option or updating to the latest version of Wings are the only known workarounds. Patches https://github.com/pterodactyl/wings/commit/5415f8ae07f533623bd8169836dd7e0b933964de

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gqmf-jqgv-v8fw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-34066

Advisory: Pterodactyl Wings vulnerable to Arbitrary File Write/Read
IDs: CVE-2024-34066, GHSA-gqmf-jqgv-v8fw
Record: https://patchnext.com/advisories/cve-2024-34066 (revision 1, source checked 26 Oct 2026, 15:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pterodactyl/wings 1.11.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pterodactyl/wings: affected < 1.11.12; fixed in 1.11.12

## Suggested inspection (read-only)
- Go github.com/pterodactyl/wings: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pterodactyl/wings.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gqmf-jqgv-v8fw (GitHub-reviewed advisory GHSA-gqmf-jqgv-v8fw lists affected ranges: Go github.com/pterodactyl/wings >=0 <1.11.12)

Commands are suggestions: review each one before running it.

Loading voting…