changedetection.io Cross-site Scripting vulnerability
CVE-2024-34061GHSA-pwgc-w4x9-gw67
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.45.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI changedetection-io
- Affected
- < 0.45.22
- Fixed in
- 0.45.22
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pwgc-w4x9-gw67 lists affected ranges: PyPI changedetection-io >=0 <0.45.22 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pwgc-w4x9-gw67 lists affected ranges: PyPI changedetection-io >=0 <0.45.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- EPSS
- CVE-2024-34061: 1.28% estimated exploitation activity in the next 30 days; percentile 70.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Input in parameter notificationurls is not processed resulting in javascript execution in the application Details changedetection.io version: v0.45.21 https://github.com/dgtlmoon/changedetection.io/blob/0.45.21/changedetectionio/forms.py#L226 PoC Setting ADD Notification URL List Requests Impact A reflected XSS vulnerability happens when the user input from a URL or POST data is reflected on the page without being stored, thus allowing the attacker to inject malicious content
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pwgc-w4x9-gw67
- Revision 1 · created ·
Published from osv record GHSA-pwgc-w4x9-gw67
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-34061 Advisory: changedetection.io Cross-site Scripting vulnerability IDs: CVE-2024-34061, GHSA-pwgc-w4x9-gw67 Record: https://patchnext.com/advisories/cve-2024-34061 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.45.22. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI changedetection-io: affected < 0.45.22; fixed in 0.45.22 ## Suggested inspection (read-only) - `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on changedetection-io. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pwgc-w4x9-gw67 (OSV record GHSA-pwgc-w4x9-gw67 lists affected ranges: PyPI changedetection-io >=0 <0.45.22 (fixed)) - Verified: https://github.com/advisories/GHSA-pwgc-w4x9-gw67 (GitHub-reviewed advisory GHSA-pwgc-w4x9-gw67 lists affected ranges: PyPI changedetection-io >=0 <0.45.22) Commands are suggestions: review each one before running it.
Loading voting…